Bug 961032 - [sanlock] wdmd should select correct watchdog device
Summary: [sanlock] wdmd should select correct watchdog device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-08 15:06 UTC by David Teigland
Modified: 2013-11-21 11:49 UTC (History)
3 users (show)

Fixed In Version: sanlock-2.8-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 11:49:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1632 normal SHIPPED_LIVE sanlock bug fix and enhancement update 2013-11-21 01:32:25 UTC

Description David Teigland 2013-05-08 15:06:41 UTC
Description of problem:

On some systems, multiple watchdog devices appear, some functional and some not.
wdmd needs to select the one that works.

See Fedora bug 878119

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Teigland 2013-06-26 16:32:19 UTC
For more information about testing this, see fedora bug 878119.
You need watchdog hardware that exposes both /dev/watchdog0 and
/dev/watchdog1, where watchdog0 is not fully functional.

Comment 4 Leonid Natapov 2013-08-26 13:05:36 UTC
(In reply to David Teigland from comment #1)
> For more information about testing this, see fedora bug 878119.
> You need watchdog hardware that exposes both /dev/watchdog0 and
> /dev/watchdog1, where watchdog0 is not fully functional.

David,can we test it without watchdog hardware ?

Comment 5 David Teigland 2013-08-26 14:47:12 UTC
I would just ensure there are no regressions in the existing tests.
It may not be feasible to find and test with hardware that exposts
the dual watchdogs.

Comment 6 Leonid Natapov 2013-08-27 13:07:46 UTC
sanlock-2.8-1.el6.x86_64. No regressions were found.

Comment 8 errata-xmlrpc 2013-11-21 11:49:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1632.html


Note You need to log in before you can comment on or make changes to this bug.