Bug 961118 - User created via Katello cannot login to Foreman
User created via Katello cannot login to Foreman
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tomas Strachota
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 16:27 EDT by Og Maciel
Modified: 2014-01-27 08:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 03:50:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-05-08 16:27:10 EDT
Description of problem:

Users created through Katello cannot login to Foreman UI

Version-Release number of selected component (if applicable):

* candlepin-0.8.5-1.el6.noarch
* candlepin-selinux-0.8.5-1.el6.noarch
* candlepin-tomcat6-0.8.5-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* foreman-1.1stable-30.3849429.el6.noarch
* foreman-postgresql-1.1stable-30.3849429.el6.noarch
* katello-1.4.2-1.git.222.82e7958.el6.noarch
* katello-all-1.4.2-1.git.222.82e7958.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.37.40869e0.el6.noarch
* katello-cli-common-1.4.2-1.git.37.40869e0.el6.noarch
* katello-common-1.4.2-1.git.222.82e7958.el6.noarch
* katello-configure-1.4.3-1.el6.noarch
* katello-configure-foreman-1.4.3-1.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.222.82e7958.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.222.82e7958.el6.noarch
* katello-glue-pulp-1.4.2-1.git.222.82e7958.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch

How reproducible:


Steps to Reproduce:
1. Create a new user via the Katello UI
2. Try to login with this same user via the Foreman UI
3.
  
Actual results:

User cannot login even though it is listed in the Foreman UI

Expected results:


Additional info:

Started POST "/foreman/users/login" for 127.0.0.1 at 2013-05-08 16:23:39 -0400
Processing by UsersController#login as HTML
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"2Ud6fb6QZSQq853j0Ha7D4h9jygD2o6hNOGWSiguuK0=", "login"=>{"login"=>"omaciel", "password"=>"[FILTERED]"}, "commit"=>"Login"}
invalid user
Redirected to https://<SERVER>/foreman/users/login
Completed 302 Found in 4ms (ActiveRecord: 1.2ms)
Comment 1 Tomas Strachota 2013-05-21 11:18:10 EDT
This is actually not a bug. There's now way how to set user's password since it's plain form might not be known in the time we create in Forman. Therefore we assign a random password to every Foreman user created from Katello.

It is still possible to log in via signo which will be a single entry point. If one later wants to use only plain foreman login the solution is to log into Foreman via signo and change the user's password.

Note You need to log in before you can comment on or make changes to this bug.