Bug 961130 - Xorg freeze with upgrade to any Linux 3.8 kernel - ATI RS780
Xorg freeze with upgrade to any Linux 3.8 kernel - ATI RS780
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 17:08 EDT by Matt Olson
Modified: 2013-07-02 11:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 11:09:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (55.27 KB, text/x-log)
2013-05-08 17:10 EDT, Matt Olson
no flags Details

  None (edit)
Description Matt Olson 2013-05-08 17:08:46 EDT
Description of problem:

Desktop will periodically freeze from 15 to 120 seconds.  During freeze, system is running normally, i.e. I can ssh in from another host.  No errors have been found that correspond to these events.  I've checked Xorg.0.log, messages, etc.  

The import aspect is that this happens with every 3.8.x kernel up to 3.8.11-200.fc18.x86_64.  If I down-rev to 3.7.9, the problem goes away.  

I have three other desktops machines I manage, two of which are different ATI video chip sets.  I'm guessing this is xorg driver and hardware specific.  

Display uses radeon driver.  Card is:

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780M/RS780MN [Mobility Radeon HD 3200 Graphics]

I've watched /proc/interrupts during one of these events.  Radeon interrupts drop from 10s per second to 1 or 2 per second.  

I am running with Desktop Effect enabled.  If I drop the 'Animation speed' to slow, that seems to help.  Hard to say for sure since it's semi-random.  

Version-Release number of selected component (if applicable):
All 3.8 kernels up to at least 3.8.11-200.fc18.x86_64.

How reproducible:
Start an Xorg session and do some work.  Frequency is maybe 3-10 events per hour depending on how intensive the display tasks are (read: working only in a terminal, it seems to happen less).

I've replicated the problem both with and without an /etc/X11/xorg.conf in place.  

Steps to Reproduce:
Can not reproduce at will.  
  
Actual results:


Expected results:


Additional info:
Comment 1 Matt Olson 2013-05-08 17:10:34 EDT
Created attachment 745455 [details]
Xorg log
Comment 2 Matt Olson 2013-05-16 14:07:20 EDT
I'm seeing the same behavoir on 3.9.2-200.fc18.x86_64.
Comment 3 Matt Olson 2013-05-16 15:04:37 EDT
I'm testing with 'nosmp' kernel boot option today on 3.9.2-200 to see if that helps.
Comment 4 Matt Olson 2013-05-16 15:10:38 EDT
No dice.  Locked up with SMP disabled.
Comment 5 Matt Olson 2013-05-23 16:19:18 EDT
I'm beginning to think this may be a thermal issue.  I dusted out the main heat sync; top end temp was >203F, now is about 190F.  I'm still seeing freezes, however, they're much shorter in duration, 1-2 seconds.  

Maybe something about 3.8/3.9 pushes the graphics hardware a little harder/hotter.  

Since no one else is reporting an issue, I'll assume this is local to me.  

Feel free to resolve.
Comment 6 Josh Boyer 2013-07-02 11:09:10 EDT
Closing out per comment #5.  If you're still seeing hangs and you start seeing errors associated with them, please open a new bug with the relevant information.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.