Bug 961142 - F19-on-F19, GDM/GNOME: Reboot from host does nothing at GDM, triggers suspend from within GNOME, works as expected from a console
F19-on-F19, GDM/GNOME: Reboot from host does nothing at GDM, triggers suspend...
Status: CLOSED DUPLICATE of bug 744077
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 18:05 EDT by Adam Williamson
Modified: 2013-05-08 18:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 18:36:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XML of the guest (2.94 KB, text/plain)
2013-05-08 18:07 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-05-08 18:05:19 EDT
This is 100% reproducible for me, but could be affected by my guest machine config, I guess.

My host here is running F19 (my regular desktop). I have a VM into which I've done a normal install of F19 Beta TC3.

If I boot the guest to multi-user.target (runlevel 3, console only) and trigger a Reboot from the host (in virt-manager's guest window, click Shut Down then Reboot from the top bar), the system reboots (very swiftly; doesn't look like a clean shutdown, though IMBW).

If I boot the guest normally and leave it at GDM, and trigger a Reboot from the host, nothing at all happens.

If I boot the guest normally, log in to GNOME, and trigger a Reboot from the host, the guest suspends instead of rebooting. If I then resume the guest and run 'shutdown' from a console, the guest reboots instead of shutting down.

Looks like there's some kind of wacky interaction between libvirt and GNOME, here?
Comment 1 Adam Williamson 2013-05-08 18:07:42 EDT
Created attachment 745467 [details]
XML of the guest
Comment 2 Eric Blake 2013-05-08 18:36:12 EDT

*** This bug has been marked as a duplicate of bug 744077 ***
Comment 3 Eric Blake 2013-05-08 18:37:47 EDT
I've been begging GNOME developers to fix their default handling of ACPI wihtin a guest since at least F16.

Meanwhile, we _still_ don't have out-of-the-box guest agent working, which would also let us avoid the need to react to ACPI in the first place.

Note You need to log in before you can comment on or make changes to this bug.