Bug 961144 - skype crashes after glib2 update
skype crashes after glib2 update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 18:12 EDT by nucleo
Modified: 2013-06-02 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-02 09:42:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 698716 None None None Never

  None (edit)
Description nucleo 2013-05-08 18:12:14 EDT
Description of problem:
Skype crashes after glib2 update.

Version-Release number of selected component (if applicable):
glib2-2.37.0-1.fc20.i686

Actual results:
skype-2.2.0.35-fc10:
Program received signal SIGSEGV, Segmentation fault.
0x08072b28 in malloc@plt ()

skype-4.1.0.20-fc16:
Program received signal SIGSEGV, Segmentation fault.
0x08075f81 in QWebPage::qt_metacast ()


Additional info:
Downgrading to gdk-pixbuf2-2.28.1-1.fc20.i686.rpm glib2-2.36.1-2.fc20.i686.rpm fixes crash both in skype-2.2.0.35 and skype-4.1.0.20.

Workarounds "LD_PRELOAD=/usr/lib/libGL.so.1 skype" and downgrading qtwebkit from this bug https://bugs.launchpad.net/ubuntu/+source/qtwebkit-source/+bug/1131636 don't work because crash happens with xorg-x11-drv-vmware driver in VM (nvidia driver in that bug).

This bug can be related with crashes in F19 from bug 949553 see comment 19 and 20 here https://bugzilla.gnome.org/show_bug.cgi?id=698716#c19

See also https://bugs.archlinux.org/task/34630
https://bugzilla.gnome.org/show_bug.cgi?id=687763
Comment 1 Kalev Lember 2013-06-02 09:42:27 EDT
The upstream report mentions that new Skype 4.2 release works fine with current glib2; closing the ticket.

Note You need to log in before you can comment on or make changes to this bug.