Bug 961145 - git version update on openshift
git version update on openshift
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Troy Dawson
libra bugs
: SupportQuestion
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 18:18 EDT by baojun.xu
Modified: 2015-05-14 19:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:48:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description baojun.xu 2013-05-08 18:18:19 EDT
I am having an error with git clone on jenkins: http://pastebin.com/NLhEBFek

According to information from github there is a bug using git version older than 1.7.9, which causes this error. The git version on openshift is 1.7.1

*******************************************
That error comes from a bug in older versions of Git triggered by having refs of the following form in your repository:

5e88ff0f57282231ff3de9c81891b509957104ff refs/for/refs/heads/master

Git versions 1.7.9 and later will get you past this error. Your upgrade to Ubuntu seems to have cleared things up.

Let me know if you have any other questions.

Brian
GitHub Support
*******************************************

I need to know when is the update of git on openshift to 1.7.9 or newer scheduled.
Comment 1 manoj 2013-05-24 15:03:35 EDT
Troy,

Any updates on this?
Comment 2 Troy Dawson 2013-05-24 18:07:19 EDT
Hi,
I'm sorry for the delay.  We are still looking into this.

We are currently using the git from RHEL6, and would like to continue to do so.  I am looking for the git bug, so we can open a bugzilla against the RHEL6 git.  Give them a chance to either update of fix the bug in our version.

We also have a couple of our git experts (which I am not) looking into a workaround incase this takes much longer.

Troy
Comment 3 Troy Dawson 2013-06-17 16:35:13 EDT
I am no longer waiting for RHEL.  We plan on putting git 1.8.2 onto the online machines.  1.8.2 is the version in Fedora and EPEL.
Due to the changes in API's and configuration files between 1.7.1 and 1.8.2 we are proceeding cautiously and testing at each step.
Comment 4 Meng Bo 2013-06-19 02:16:51 EDT
git updated to 1.8.21 on devenv_3383

[root@ip-10-154-152-232 ~]# rpm -qa|grep git-1
git-1.8.2.1-1.el6oso.x86_64
[root@ip-10-154-152-232 ~]# git --version
git version 1.8.2.1

Note You need to log in before you can comment on or make changes to this bug.