Bug 961165 - DeviceCreateError: ('mdcreate failed for /dev/md/nameroot: running mdadm --create /dev/md/nameroot --run --level=0 --raid-devices=4 --metadata=1.0 --bitmap=internal /dev/sda1 /dev/sdb1 /dev/sdc1 /dev/sdd1 failed', 'nameroot')
DeviceCreateError: ('mdcreate failed for /dev/md/nameroot: running mdadm --cr...
Status: CLOSED DUPLICATE of bug 960271
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:ea7f6e7fd9927be6abcc8b350d8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 22:36 EDT by Chris Murphy
Modified: 2013-05-08 22:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 22:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (579.65 KB, text/plain)
2013-05-08 22:36 EDT, Chris Murphy
no flags Details
File: anaconda.log (22.55 KB, text/plain)
2013-05-08 22:36 EDT, Chris Murphy
no flags Details
File: backtrace (1.21 KB, text/plain)
2013-05-08 22:36 EDT, Chris Murphy
no flags Details
File: environ (769 bytes, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details
File: lsblk_output (3.26 KB, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details
File: messages (146.52 KB, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details
File: nmcli_dev_list (3.40 KB, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details
File: program.log (32.31 KB, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details
File: storage.log (362.34 KB, text/plain)
2013-05-08 22:37 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-05-08 22:36:31 EDT
Description of problem:
Changed to device type RAID. Clicked Apply. Changed to raid0, clicked Apply. Beging installation.
The following was filed automatically by anaconda:
anaconda 19.24-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 789, in create
    raise DeviceCreateError(str(e), self.name)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 272, in execute
    self.device.create()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 303, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 162, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 117, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
DeviceCreateError: ('mdcreate failed for /dev/md/nameroot: running mdadm --create /dev/md/nameroot --run --level=0 --raid-devices=4 --metadata=1.0 --bitmap=internal /dev/sda1 /dev/sdb1 /dev/sdc1 /dev/sdd1 failed', 'nameroot')

Version-Release number of selected component:
anaconda-19.24-1.fc19.x86_64

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
other involved packages: python-blivet-0.12-1.fc19.noarch, python-libs-2.7.4-3.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
ureports_counter: 1
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 117, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 162, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 303, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 272, in execute
    self.device.create()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 789, in create
    raise DeviceCreateError(str(e), self.name)
DeviceCreateError: ('mdcreate failed for /dev/md/nameroot: running mdadm --create /dev/md/nameroot --run --level=0 --raid-devices=4 --metadata=1.0 --bitmap=internal /dev/sda1 /dev/sdb1 /dev/sdc1 /dev/sdd1 failed', 'nameroot')
Comment 1 Chris Murphy 2013-05-08 22:36:41 EDT
Created attachment 745503 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2013-05-08 22:36:55 EDT
Created attachment 745504 [details]
File: anaconda.log
Comment 3 Chris Murphy 2013-05-08 22:36:59 EDT
Created attachment 745505 [details]
File: backtrace
Comment 4 Chris Murphy 2013-05-08 22:37:04 EDT
Created attachment 745506 [details]
File: environ
Comment 5 Chris Murphy 2013-05-08 22:37:06 EDT
Created attachment 745507 [details]
File: ifcfg.log
Comment 6 Chris Murphy 2013-05-08 22:37:08 EDT
Created attachment 745508 [details]
File: lsblk_output
Comment 7 Chris Murphy 2013-05-08 22:37:12 EDT
Created attachment 745509 [details]
File: messages
Comment 8 Chris Murphy 2013-05-08 22:37:17 EDT
Created attachment 745510 [details]
File: nmcli_dev_list
Comment 9 Chris Murphy 2013-05-08 22:37:19 EDT
Created attachment 745511 [details]
File: program.log
Comment 10 Chris Murphy 2013-05-08 22:37:28 EDT
Created attachment 745512 [details]
File: storage.log
Comment 11 Chris Murphy 2013-05-08 22:37:56 EDT

*** This bug has been marked as a duplicate of bug 960271 ***

Note You need to log in before you can comment on or make changes to this bug.