This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 961190 - date types do not have 'is not' operator in search bar
date types do not have 'is not' operator in search bar
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.12
Unspecified Unspecified
low Severity low (vote)
: ---
: ---
Assigned To: Amit Saha
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 01:09 EDT by Raymond Mancy
Modified: 2014-12-07 20:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 02:35:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2013-05-09 01:09:27 EDT
Description of problem:

Cannot search a date type column by 'is not'

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Go to systems page
2. Select Systems/Added
3.
  
Actual results:

no 'is not' operation

Expected results:

Should be one

Additional info:
Comment 1 xjia 2013-06-04 02:35:32 EDT
It can't reproduce on beaker-devel. So close it as current release.
Comment 2 Nick Coghlan 2013-06-04 03:24:49 EDT
This one is technically valid - if you choose "System/Added" or "System/LastInventoried" as your search option, the only operations presented are "after", "before" and "is".

The reason "is not" makes sense is that in the System/LastInventoried case, it makes sense to search for "is not <blank>" to get all of the systems which have actually been inventoried.

It's very low priority though, as you can get an equivalent search by using a filter like "<date field> after <date before the Beaker instance was set up>", such as:

  System/LastInventoried after 01-01-2000

Given the number of real improvements on our TODO list, I think I'm going to call "Won't Fix" on this one :)

Note You need to log in before you can comment on or make changes to this bug.