Bug 961277 - RFE: Accept job containing tasks that are not in task library if alternative harness is specified for this job
RFE: Accept job containing tasks that are not in task library if alternative ...
Status: CLOSED DUPLICATE of bug 1057459
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.12
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Dan Callaghan
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 06:33 EDT by Ľuboš Kardoš
Modified: 2016-07-31 21:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-16 23:08:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
job xml (1.21 KB, text/xml)
2013-05-09 06:33 EDT, Ľuboš Kardoš
no flags Details

  None (edit)
Description Ľuboš Kardoš 2013-05-09 06:33:59 EDT
Created attachment 745609 [details]
job xml

Description of problem:
Beaker doesn't accept job containing task that are not in task librarary. But if for a job is alternative harness specified (not beah) by adding parameter "harness=..." into ks_meta and this alternative harness uses git for downloading tasks, there is no need to check if this task is in task library. 

Version-Release number of selected component (if applicable):
beaker 0.12.1

How reproducible:
always

Steps to Reproduce:
1.Schedule job with attached job XML.
  
Actual results:
Beaker shows message "Failed to import job because of: u'Invalid task(s): install_log'" because the task "install_log" is not in beaker task library.

Expected results:
Beaker should accept this job because this job uses alternative harness that downloads tasks from git and not from beaker task library.


Additional info:
Comment 1 Bill Peck 2013-05-09 08:30:46 EDT
When I talked to Dan about this we agreed that if a task included a <fetch> node that beaker wouldn't attempt to look it up in it's database.  So the following would tell beaker to simply pass the info along to the harness which would install direct from git.

<task name="/my/task" role="STANDALONE">
 <fetch url="git://git.beaker-project.org/git_repo?branch#path/to/my/task"/>
</task>

I really hope this can be added to 1.0
Comment 2 Nick Coghlan 2013-11-04 20:37:14 EST
Related patches:

fetch_url support: http://gerrit.beaker-project.org/2365
Draft external tasks proposal: http://gerrit.beaker-project.org/2366
Comment 3 Dan Callaghan 2014-03-16 23:08:37 EDT
This was proposed as "External Tasks for Jobs":

https://beaker-project.org/dev/proposals/external-tasks.html

and implemented in the 0.16 release: bug 1057459.

*** This bug has been marked as a duplicate of bug 1057459 ***

Note You need to log in before you can comment on or make changes to this bug.