Bug 961290 - PSQLException: Large Objects may not be used in auto-commit mode
PSQLException: Large Objects may not be used in auto-commit mode
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Edson Tirelli
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 07:07 EDT by Jiri Locker
Modified: 2013-05-09 11:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
PostgreSQL 9.2
Last Closed: 2013-05-09 11:00:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (63.76 KB, text/plain)
2013-05-09 07:07 EDT, Jiri Locker
no flags Details

  None (edit)
Description Jiri Locker 2013-05-09 07:07:46 EDT
Created attachment 745613 [details]
server.log

Description of problem:
kie-ide fails to deploy due to this exception when persistence is configured with PostgreSQL datasource.

Version-Release number of selected component (if applicable):
DR4

Steps to Reproduce:
1. setup pgsql datasource on eap 6.1
2. change kie-ide.war/<...>/persistence.xml to use pgsql datasource
3. start the server
  
Additional info:
See attached server.log for full exception trace.
Comment 1 Jiri Locker 2013-05-09 07:12:49 EDT
Similar issue with LOBs and PostgreSQL has been fixed for 5.3: bug 852044.
Comment 2 Jiri Locker 2013-05-09 08:00:29 EDT
Probably error in my configuration. When creating datasource in EAP admin console jta attribute of the datsource defaults to true. I didn't check this. Setting jta="true" avoids the exception an kie-ide deploys OK.

Please close as not a bug if this behavior is correct.
Comment 3 Jiri Locker 2013-05-09 08:02:04 EDT
> defaults to true
should be "defaults to false"

Note You need to log in before you can comment on or make changes to this bug.