Bug 961323 - After restarting dnsmasq, all information of still valid leases is lost
After restarting dnsmasq, all information of still valid leases is lost
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dnsmasq (Show other bugs)
5.6
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tomáš Hozza
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 08:21 EDT by Jay Lowe
Modified: 2013-10-31 05:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 05:48:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Lowe 2013-05-09 08:21:30 EDT
Description of problem:

After restarting dnsmasq, all information of still valid leases is lost.
Hostnames won't resolve until the client refreshes the lease.


Version-Release number of selected component (if applicable):


How reproducible:
not very

Steps to Reproduce:
1. stop dnsmasq service
2. start dnsmasq service
3. check leases file
  
Actual results:
leases file is empty

Expected results:
leases file will be populated 

Additional info:
Comment 1 Jay Lowe 2013-05-09 10:07:56 EDT
If version 2.6.6 is out, why doesnt RedHat suport it?
Comment 2 Ondrej Vasik 2013-05-09 14:59:46 EDT
Because RHEL-5 is now in production phase 2 - see https://access.redhat.com/support/policy/updates/errata/ . Red Hat Enterprise Linux keeps old packages and backports just the fixes/features important for customers - as rebases may break the setup of the customers. Please, don't expect dnsmasq 2.66 in RHEL-5.

In addition - as I said - we are now in production phase 2. Thus, updates are driven by customer requests. Bugzilla is bug tracking tool, but not a tool for support/customer requests. 


If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain  it receives the proper attention and prioritization to assure a timely resolution. 

 

For information on how to contact the Red Hat production support team, please visit: https://www.redhat.com/support/process/production/#howto
Comment 3 Tomáš Hozza 2013-10-31 05:48:52 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.

Note You need to log in before you can comment on or make changes to this bug.