Bug 961336 - Syntactic error in .postinstall script in version for RHEL
Syntactic error in .postinstall script in version for RHEL
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Apache Server (httpd) and Connectors (Show other bugs)
6.1.0
Unspecified Linux
unspecified Severity urgent
: ER8
: EAP 6.1.0
Assigned To: Permaine Cheung
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 08:35 EDT by Radim Hatlapatka
Modified: 2015-02-20 05:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 14:38:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2013-05-09 08:35:28 EDT
During our acceptance testing we have found regression from EAP 6.1.0.ER6.

There is a syntax error in .postinstall script for RHEL platform. This regression causes incomplete installation process which can lead to invalid configuration setting of httpd.

./.postinstall: line 43: syntax error near unexpected token `fi'
./.postinstall: line 43: `fi'


The 'fi' is supposed to be commented out as well.
Comment 1 Permaine Cheung 2013-05-09 08:45:22 EDT
Weinan, please investigate.
Comment 4 Permaine Cheung 2013-05-09 12:11:43 EDT
Fixed in jboss-eap6-httpd-natives-6.1.0-5.ep6.el6, incorporated into jboss-eap6-natives-compose-6.1.0-15.CR1.ep6.el6.
Comment 5 Pavel Janousek 2013-05-10 04:20:41 EDT
Verified during EAP-6.1.0-ER8 test cycle. looks fixed.

Note You need to log in before you can comment on or make changes to this bug.