Bug 961354 - realmd should enable site discovery in sssd for AD domains
realmd should enable site discovery in sssd for AD domains
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 959458
  Show dependency treegraph
 
Reported: 2013-05-09 09:13 EDT by Stef Walter
Modified: 2013-05-13 10:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 09:08:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2013-05-09 09:13:17 EDT
We should enable site discovery like this by default in the sssd.conf for AD domains:

https://fedoraproject.org/wiki/QA:Testcase_sssd_ad_dns_sites
Comment 1 Stef Walter 2013-05-13 09:08:47 EDT
I think that the default value for ad_servers is '_srv_'. So it's not necessary to change our behavior here. This already works as expected, because we don't add an ad_servers unless realmd was passed an explicit server.

Jakub, could you correct me if I'm wrong here.
Comment 2 Jakub Hrozek 2013-05-13 10:31:21 EDT
(In reply to comment #1)
> I think that the default value for ad_servers is '_srv_'. So it's not
> necessary to change our behavior here. This already works as expected,
> because we don't add an ad_servers unless realmd was passed an explicit
> server.
> 

Correct, so if realmd doesn't set any value for ad_servers, then SSSD would start service discovery.

> Jakub, could you correct me if I'm wrong here.

Correct. There is also an option (ad_enable_dns_sites) that can be used to toggle the site discovery on/off, but it's currently set to "true" by default.

I think that realmd is doing the right thing as it is.

Note You need to log in before you can comment on or make changes to this bug.