Bug 961358 - When installing RHEL-5.9 guest using PXE on Fedora, whole PC freezes
When installing RHEL-5.9 guest using PXE on Fedora, whole PC freezes
Status: CLOSED DUPLICATE of bug 954181
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 09:18 EDT by Tomáš Hozza
Modified: 2013-05-17 10:53 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 10:53:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Guest XML (2.41 KB, text/plain)
2013-05-17 07:14 EDT, Tomáš Hozza
no flags Details
Screenshot 1 (5.31 MB, image/png)
2013-05-17 07:38 EDT, Tomáš Hozza
no flags Details
Screenshot 2 (4.63 MB, image/png)
2013-05-17 07:38 EDT, Tomáš Hozza
no flags Details

  None (edit)
Description Tomáš Hozza 2013-05-09 09:18:34 EDT
Description of problem:
When installing RHEL-5.9 guest using PXE on Fedora, whole PC freezes.
I have to shut it down using power button to restart it.

Version-Release number of selected component (if applicable):
libvirt-0.10.2.4-1.fc18
virt-manager-0.9.5-1.fc18

How reproducible:
Always and also on different Hosts with separate Fedora 18 instalation

Steps to Reproduce:
1. open virt-manager
2. create new guest
3. turn it off, set up network to be bridged with Host ethernet controller
4. turn on the Guest
5. Boot RHEL-5.9 installation using PXE
/* this may have no effect on the bug */
6. use default language and keyboard settings, turn off IPv6
7. after that the initial text mode switches to graphical installation UI
8. whole Host system freezes after switching to graphical UI

Actual results:
Whole Host system freezes after switching to graphical UI

Expected results:
Host system will NOT freeze after switching to graphical UI

Additional info:
Once it freezed right before switching to the graphical UI.
The installation output showed something like:
"initializing video device 0100 Red Hat Inc."
So maybe this has something to do with video device in libvirt (my guess).
Comment 1 Dave Allan 2013-05-09 10:12:02 EDT
Hey Tomas, libvirt's a userspace component, so I'd be surprised if it was the thing locking up the host, but let's see if we can figure out what's going on here.  A few questions: can you provide the guest XML; does the guest OS make a difference; can you ssh into the host while it's in this state?
Comment 2 Tomáš Hozza 2013-05-17 07:08:00 EDT
(In reply to comment #1)
> Hey Tomas, libvirt's a userspace component, so I'd be surprised if it was
> the thing locking up the host, but let's see if we can figure out what's
> going on here.A few questions: can you provide the guest XML

I'll attach it to this Bug.

> does the guest OS make a difference

Well yes. I have problems only when installing RHEL-5-9 (and also with
latest RHEL-5.10 nightly snapshot). With the latest nightly snapshot I
was able to get further than with RHEL-5.9 but instead of freezing my
host kernel crashed. I'll attach picture of what I got on my screen.

I'm using kernel-3.9.2-200.fc18.x86_64

> can you ssh into the host while it's in this state?

ssh is not working after the host freezes, but I was still able to ping the
host.
Comment 3 Tomáš Hozza 2013-05-17 07:14:33 EDT
Created attachment 749296 [details]
Guest XML

I replaced MAC address of the network interface with "xx:xx:xx:xx:xx:xx"
since it is my physical interface's MAC.
Comment 4 Tomáš Hozza 2013-05-17 07:38:03 EDT
Created attachment 749327 [details]
Screenshot 1
Comment 5 Tomáš Hozza 2013-05-17 07:38:39 EDT
Created attachment 749328 [details]
Screenshot 2
Comment 6 Tomáš Hozza 2013-05-17 07:47:52 EDT
(In reply to comment #4)
> Created attachment 749327 [details]
> Screenshot 1

(In reply to comment #5)
> Created attachment 749328 [details]
> Screenshot 2

Sorry for the bad quality of pictures, but this is the best I'm able to take
with my phone's camera.

ABRT is reporting that there was a kernel oops but the Kernel was tainted
(flags: GFD).

G - Proprietary module has been loaded
F - Module has been forcibly loaded
D - Kernel has oopsed before

tainted modules are: tpm_tis, joydev

Hope this helps to find out what might be causing this, but I'm not sure if this
is libvirt Bug or kernel Bug.
Comment 7 Dave Allan 2013-05-17 09:45:29 EDT
(In reply to comment #6)
> Hope this helps to find out what might be causing this, but I'm not sure if
> this is libvirt Bug or kernel Bug.

This is definitely not a libvirt bug; I'm changing the component to kernel, but I suspect you're not going to get a lot of interest from the kernel folks unless you can reproduce on an untainted kernel.
Comment 8 Tomáš Hozza 2013-05-17 09:50:16 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Hope this helps to find out what might be causing this, but I'm not sure if
> > this is libvirt Bug or kernel Bug.
> 
> This is definitely not a libvirt bug; I'm changing the component to kernel,
> but I suspect you're not going to get a lot of interest from the kernel
> folks unless you can reproduce on an untainted kernel.

Thanks! I'm using *default* Fedora kernel without any 3rd party modules and
it is happening on any Fedora 18 installation (I tested on 3 different hosts)
so I think they should be interested...
Comment 9 Tomáš Hozza 2013-05-17 09:59:07 EDT
I should also mention that this issue happens also if I unload "tpm_tis"
and "joydev" modules from kernel.
Comment 10 Josh Boyer 2013-05-17 10:53:51 EDT
Based on the stack trace involving macvlan, macvtap, and vhost_net, I'm going to mark this as a duplicate of 954181

*** This bug has been marked as a duplicate of bug 954181 ***

Note You need to log in before you can comment on or make changes to this bug.