Bug 961363 - AD DNS timestamps have strange values
AD DNS timestamps have strange values
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 09:27 EDT by David Spurek
Modified: 2015-03-02 00:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 11:43:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2013-05-09 09:27:36 EDT
Description of problem:
AD DNS timestamps have strange values. SSSD is configured with 'dyndns_update = True' entry. But DNS timestamp in AD have strange value after the entry is added. Here is an example:

Date on AD machine is '5/9/2013 3:24 PM', but added DNS entry has timestamp '5/9/2013 3:00:00'

I think it is strange, but maybe it is a problem on AD side.


Version-Release number of selected component (if applicable):


How reproducible:
sssd-1.10.0-4.fc19

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Hrozek 2013-05-09 09:56:35 EDT
SSSD has nothing to do with the timestamps, it just sends the nsupdate to AD, the timestamps are generated by AD.
Comment 2 Jakub Hrozek 2013-05-16 11:43:24 EDT
I double checked the Microsoft documentation to make sure the timestamps are expected. Turns out they are, AD generates the timestamps rounded down to the nearest hour:

See for example:
http://blogs.technet.com/b/networking/archive/2008/03/19/don-t-be-afraid-of-dns-scavenging-just-be-patient.aspx?Redirected=true

But you're right that we didn't mention this explicitly prior to the test day. I will amend our test plans accordingly. Thanks!

Note You need to log in before you can comment on or make changes to this bug.