Bug 961365 - SY quickstart bean-service JBDS warnings
SY quickstart bean-service JBDS warnings
Status: CLOSED UPSTREAM
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples, SwitchYard (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Fitzpatrick
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 09:31 EDT by ppecka
Modified: 2015-08-02 19:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When you start the JBoss Developer Studio and import an existing maven project, the server generates bean-service JBDS warnings. There is no functional impact.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 13:26:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 415786 None None None Never

  None (edit)
Description ppecka 2013-05-09 09:31:37 EDT
Description of problem:
Description	Resource	Path	Location	Type
No bean is eligible for injection to the injection point [JSR-299 ยง5.2.1]	OrderServiceBean.java	/switchyard-quickstart-bean-service/src/main/java/org/switchyard/quickstarts/bean/service	line 30	CDI Problem
WS-I: (AP2901) A description uses neither the WSDL MIME Binding as described in WSDL 1.1 Section 5 nor WSDL SOAP binding as described in WSDL 1.1 Section 3 on each of the wsdl:input or wsdl:output elements of a wsdl:binding.	OrderService.wsdl	/switchyard-quickstart-bean-service/src/main/resources/wsdl	line 59	WSDL Problem
WS-I: (BP2402) The wsdl:binding element does not use a soapbind:binding element as defined in section "3 SOAP Binding." of the WSDL 1.1 specification.	OrderService.wsdl	/switchyard-quickstart-bean-service/src/main/resources/wsdl	line 0	WSDL Problem
Comment 1 ppecka 2013-05-14 04:00:37 EDT
Description:
Warnings/Errors found in JBDS "Problems" View, right after quickstart is imported as maven project.

steps to reproduce:
1. Start JBDS
2. import existing maven project
3. Window / Show View / Problems
4. check for errors
Comment 2 Brian Fitzpatrick 2013-08-23 11:24:10 EDT
The CDI error was resolved by prior fixes. Am looking into fixing the WSDL warnings.
Comment 3 Brian Fitzpatrick 2013-08-23 14:07:29 EDT
We believe the two WSDL warnings are being reported erroneously by the Eclipse WSDL validator. We have created BZ 415786 at Eclipse to report the issue. 

We believe these messages are reported in error and that the validator isn't respecting SOAP 1.2 extensions for WSDL as documented here: http://www.w3.org/Submission/wsdl11soap12/

It seems to be looking for the SOAP 1.1 binding, which is not required.

In the meantime we will need to accept the warnings for now or turn off WSDL validation. (Windows->Preferences, Validation, find the "WSDL Validator" entry and uncheck the Manual and Build boxes.
Comment 4 Brian Fitzpatrick 2013-09-09 11:29:05 EDT
See previous comment. We need to report these warnings upstream.
Comment 5 Brian Fitzpatrick 2013-09-09 13:26:03 EDT
Upstream warnings. Report bug against WTP if this is critical.

Note You need to log in before you can comment on or make changes to this bug.