Bug 961366 - Error on clicking 'Get Live Value' button for a metric on resource->Monitoring->Tables tab
Error on clicking 'Get Live Value' button for a metric on resource->Monitorin...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks: 1024981
  Show dependency treegraph
 
Reported: 2013-05-09 09:31 EDT by Sunil Kondkar
Modified: 2014-01-02 15:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1024981 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server_log (33.01 KB, text/plain)
2013-05-09 09:32 EDT, Sunil Kondkar
no flags Details
Screenshot-Tables_GetLiveValue (102.07 KB, image/png)
2013-05-09 09:33 EDT, Sunil Kondkar
no flags Details
Screenshot-Traits_GetLiveValue (101.53 KB, image/png)
2013-05-09 09:33 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2013-05-09 09:31:40 EDT
Description of problem:

Selecting a metric and clicking 'Get Live Value' button on resource->Monitoring->Tables tab displays error 'Cannot get live values for those metrics. Make sure the agent is running and the managed resource is up.' in UI and stack trace in server log.

Please refer the attached screenshot and stack trace in server log.

Version-Release number of selected component (if applicable):

Version: 3.2.0.ALPHA_QA
Build Number: edb3aa6:6964581
Platform: RHEL 5 - release 5.7 (Tikanga)
Java version "1.6.0_18"
Database: PostgreSQL 8.3.8
Browser Version: Firefox 10.0.2

How reproducible:

Always

Steps to Reproduce:

1. Install JON 3.2 Alpha 25 build
2. Login to JBoss ON
3. Navigate to resource->Monitoring->Tables tab ( Ex: Resource CPU 0)
4. Select a metric (Ex: System Load )
5. Click on the button 'Get Live Value'.
  
Actual results:

Error in UI on clicking 'Get Live Value' button for a metric on resource->Monitoring->Tables tab

Expected results:

No error and it should display the live value for the selected metric.

Additional info:

Observed the same error when user selects a trait on resource->Monitoring->Traits tab and clicks on 'Get Live Value' button.
Comment 1 Sunil Kondkar 2013-05-09 09:32:31 EDT
Created attachment 745662 [details]
Server_log
Comment 2 Sunil Kondkar 2013-05-09 09:33:20 EDT
Created attachment 745663 [details]
Screenshot-Tables_GetLiveValue
Comment 3 Sunil Kondkar 2013-05-09 09:33:48 EDT
Created attachment 745664 [details]
Screenshot-Traits_GetLiveValue
Comment 4 John Mazzitelli 2013-05-13 14:52:05 EDT
This is the same symptom and same stack trace as bug #956388 which has been fixed (look at the server log attachment on that BZ and the line numbers for the NPE in MeasuermentManagerDataBean are the same. The NPE was a result of autoboxing a null Long into a long. But the API now uses Long. That BZ was verified.

So I'm not sure what is going on. Is it possible you were using an old build that didn't have this fix in it? I just checked the code in master and its using the fixed API so this should not be happening assuming the build you tested with was based off of master since that fix for bug #956388 went in.
Comment 6 Thomas Segismont 2013-07-19 03:19:59 EDT
Tested a master branch build and it works as Mazz mentioned.
Comment 7 Simeon Pinder 2013-07-23 10:19:59 EDT
Moving this to ON_QA as available for test in brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=282751
Comment 8 Larry O'Leary 2013-09-06 10:31:24 EDT
As this is MODIFIED or ON_QA, setting milestone to ER1.
Comment 9 Armine Hovsepyan 2013-09-24 14:06:02 EDT
verified get Live on UI 
no exception in logs and/or UI
Comment 10 Libor Zoubek 2013-09-26 05:58:37 EDT
I need to reopen this BZ (JON 3.2.ER1), because when I click "Get Live Value" metric table just refreshes.

Steps (for max-pool-size on AS7 datasource:
1. enable max-pool-size setting metric (set interval to 10minutes)
2. configure max-pool-size to some other value
3. go to "Metrics", select max-pool-size setting metric
4. hit "Get Live Value"

Actual results:
metric content only refreshes, while "Last" column value is still old

Expected results:
I get Pop-up with latest value and value in "Last" column must match this live value
Comment 11 Mike Thompson 2013-10-21 15:09:03 EDT
Popup has been removed and live values have now replaced the last values in the metrics screen. Live values button has also been removed per UXD. So a "Refresh" will now pull in the live values.

Committed to master: 08fe551
Comment 12 Armine Hovsepyan 2013-10-30 11:44:03 EDT
neither get live value, nor refresh button get the live value - last value is being changes only after Refresh interval.
Comment 13 Mike Thompson 2013-10-30 13:06:55 EDT
I can see from the above commit that this is only in master. I was waiting on approval to move to jon3.2.x.
Comment 14 Mike Thompson 2013-10-30 13:40:13 EDT
@Armine please see BZ 1024981 as there was confusion regarding master versus jon3.2.0.
Comment 15 Varun Khurana 2013-11-08 15:53:40 EST
Verified on Jon 3.2 ER5

Note You need to log in before you can comment on or make changes to this bug.