Bug 961370 - With kernel 3.8.11-200 Epson 3490 scanner no longer working after poweroff. Reason: firmware no longer loads
With kernel 3.8.11-200 Epson 3490 scanner no longer working after poweroff. ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 968853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 09:40 EDT by Jean Francois Martinez
Modified: 2013-07-02 11:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 968853 (view as bug list)
Environment:
Last Closed: 2013-07-02 11:06:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2013-05-09 09:40:16 EDT
Description of problem:
I have an "EPSON 3490 Photo" scanner.  Every time it is powered off it requires its firmware being reloaded.  However with kernel 3.8.11-200 xsane waits a quite long time and then complains about an I/O error.  I have to reboot to 3.8.5-201
use sane so firmware is loaded and then reboot to 3.8.11-200.  Then it works but of course this trick will only work until a kernel upgrade pushes 3.8.5-201 into oblivion.  I cannot just let my scanner powered on since when it crashes a power-off is mandatory.


Version-Release number of selected component (if applicable):
3.8.11-200

How reproducible:
Always

Steps to Reproduce:
1. Boot with 3.8.11-200
2. Power-off scanner and then power it on again
3. Try to scan something
  
Actual results:
Sane complains of an I/O error and is unable to make the scanner work

Expected results:
A working scanner.


Additional info:
Could be unrelated but with this kernel when I do an lsusb my 3490 scanner shows up as a 3590.  I haven't tried with one of the older, working kernels. 
I also have kernel 3.8.6-203 but I haven't tested if sane can load the firmware with it.
Comment 1 Dave Jones 2013-05-31 13:38:08 EDT
*** Bug 968853 has been marked as a duplicate of this bug. ***
Comment 2 Jean Francois Martinez 2013-06-05 15:56:53 EDT
It works with kernel 3.8.6-203.

Note You need to log in before you can comment on or make changes to this bug.