Bug 961429 - A collection can get twice-enabled
A collection can get twice-enabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scl-utils (Show other bugs)
6.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Jan Zeleny
Lukas Zachar
: ZStream
Depends On: 955669
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 11:16 EDT by Libor Miksik
Modified: 2013-07-16 05:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: scl-utils-20120927-2.el6_4.5
Doc Type: Bug Fix
Doc Text:
* When starting an inspection of what collections are already enabled, a wrong variable was taken as a source of this information. In a specific case, when users ran a shell in an scl_enabled environment, and tried to enable an already-enabled collection, then the collection was enabled twice. This could have caused problems if the enable scriptlets were not prepared for something like this, and might have destroyed some parts of the original environment. This update accepts the correct variable as a source of information about the already-enabled collections, and the collections are no longer enabled multiple times.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 05:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Miksik 2013-05-09 11:16:51 EDT
This bug has been copied from bug #955669 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 errata-xmlrpc 2013-07-16 05:53:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1065.html

Note You need to log in before you can comment on or make changes to this bug.