Bug 961453 - Xorg hangs at exit in an uninterruptible sleep
Xorg hangs at exit in an uninterruptible sleep
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alon Levy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 12:25 EDT by Jeremy White
Modified: 2014-08-04 18:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-03 11:07:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy White 2013-05-09 12:25:05 EDT
Description of problem:

A Fedora core 19 guest running in qemu 4.5, if the qxl driver is used, will hang when the X server exits, and requires that qemu be manually killed.

The Xorg process is stuck in an uninterruptible sleep state.

Version-Release number of selected component (if applicable):

This problem occurs with xorg-x11-drv-qxl-0.1.1-0.4.20130312gita474a71.fc19.x86_64, but it also happens if I build from source.  I have not found a version that does not exhibit this problem (although I've only been able to successfully build back to 7f0b820d919eb944eae201de03b186bd247b0324, a September 2012 commit.

I have not yet attempted different versions of the spice server and/or qemu to see if they may be related.

How reproducible:

Highly, for me.  It's quite likely that this is a function of my environment.  I want to report is now so that it is not lost to posterity, as I've spent some time on it.  Notably, I'm using a Debian host, and most Spice devs host on Fedora on RHEL.

Steps to Reproduce:
1.  Run qemu with an f19 guest, log in
2.  Poweroff the guest
3.  Observe the hang

You can also do this more discreetly by turning off gdm and invoking Xorg directly; that lets you see the Xorg process hung in an uninterruptible sleep
  
Actual results:
Xorg, and thus system, hung

Expected results:
Normal shutdown

Additional info:
qemu version: v1.4.0-729-gf7d4209
spice version:  v0.12.2-14-g25f84a2
spice-gtk version: v0.18-31-ga0cadd9
Comment 1 Dave Airlie 2013-07-03 01:55:36 EDT
does this still happen with F19 final? can you get me a copy of the backtrace?
Comment 2 Jeremy White 2013-07-03 11:07:06 EDT
I was unable to reproduce this with F19 final.  Closing...

Note You need to log in before you can comment on or make changes to this bug.