Bug 961470 - Regression: CDI portable extensions with missing dependencies fail to deploy
Regression: CDI portable extensions with missing dependencies fail to deploy
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER1
: EAP 6.2.0
Assigned To: Stuart Douglas
Ron Šmeral
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 12:50 EDT by Ron Šmeral
Modified: 2016-10-31 21:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (52.07 KB, text/x-log)
2013-05-09 12:50 EDT, Ron Šmeral
no flags Details
Reproducer (2.68 KB, application/x-java-archive)
2013-05-09 12:55 EDT, Ron Šmeral
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1328 Major Resolved Regression: CDI portable extensions with missing dependencies fail to deploy 2014-05-09 11:09:51 EDT

  None (edit)
Description Ron Šmeral 2013-05-09 12:50:36 EDT
Created attachment 745732 [details]
Server log

Description of problem:
CDI portable extensions fail to deploy if the extension class is invalid -- has a dependency on a class unavailable to the classloader.
Note: In ER5, the extension would deploy with just a warning from Weld.
Note: This commit https://github.com/weld/core/commit/34bcce3f does not fix the extension deployment error.
The problem seems to be in the AS/Weld integration.
Possible workaround is to catch the LinkageError in org.jboss.as.weld.deployment.processors.WeldPortableExtensionProcessor, as in https://github.com/rsmeral/jboss-as/commit/014c5bbb.

Version-Release number of selected component (if applicable):
6.1.0.ER6

How reproducible:
Deploy the attached reproducer.
  
Actual results:
The deployment fails with an error (LinkageError).

Expected results:
The archive deploys with a warning.
Comment 1 Ron Šmeral 2013-05-09 12:51:28 EDT
Comment on attachment 745732 [details]
Server log

First AS run: ER7
Second run: ER7 patched: https://github.com/rsmeral/jboss-as/commit/014c5bbb
Comment 2 Ron Šmeral 2013-05-09 12:55:50 EDT
Created attachment 745734 [details]
Reproducer
Comment 5 Stuart Douglas 2013-05-09 21:52:12 EDT
Pull Request:

https://github.com/jbossas/jboss-eap/pull/147

Upstream PR:

https://github.com/wildfly/wildfly/pull/4489
Comment 9 Ivo Studensky 2013-08-15 04:38:37 EDT
This one was missed in 6.1.1 planning, thus moving it to 6.2.0.
Comment 10 Ron Šmeral 2013-09-11 06:27:40 EDT
Verified on 6.2.0.ER1.

Note You need to log in before you can comment on or make changes to this bug.