Bug 961500 - After upgrade to Fedora 19 I can no longer use Gnome
After upgrade to Fedora 19 I can no longer use Gnome
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
: Triaged
Depends On: 961636
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-05-09 14:21 EDT by Need Real Name
Modified: 2013-09-03 16:47 EDT (History)
11 users (show)

See Also:
Fixed In Version: gnome-bluetooth-3.8.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 22:26:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm log (30.08 KB, text/plain)
2013-05-15 05:01 EDT, Need Real Name
no flags Details
xorg log (30.13 KB, text/plain)
2013-05-15 05:01 EDT, Need Real Name
no flags Details
journalctl -abf --lines=0 (16.51 KB, text/plain)
2013-05-16 03:27 EDT, Need Real Name
no flags Details
gdm log :0.log (26.22 KB, text/plain)
2013-05-17 05:05 EDT, Need Real Name
no flags Details
xorg :0.log (26.22 KB, text/plain)
2013-05-17 05:14 EDT, Need Real Name
no flags Details
xorg :0.log.1 (28.97 KB, text/plain)
2013-05-17 05:15 EDT, Need Real Name
no flags Details
journalctl (21.87 KB, text/plain)
2013-05-21 05:06 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2013-05-09 14:21:50 EDT
Description of problem:
When I login from gdm, I get the not very useful "oh no!" error.

If I run:
 xinit
I get a shell. I can replace the desktop with gnome-shell.

If I run:
 xinit gnome-shell
I get the gnome desktop.

But if I run:
 xinit gnome-session
I get a crash.

More info to follow.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Need Real Name 2013-05-09 14:27:37 EDT
Here are the errors which go to the console before it all crashes (transcribed from video):

gnome-settings-daemon:4047 color-plugin-WARNING **: failed to create device: failed to obtain org.freedesktop.color-manager.create-device auth

gnome-settings-daemon:4047 color-plugin-WARNING **: failed to obtain org.freedesktop.color-manager.create-profile auth

gnome-settings-daemon:4047 color-plugin-WARNING **: failed to obtain org.freedesktop.color-manager.create-profile auth
**
Bluetooth:ERROR:rfkill-glib.c:83:type_to_string: code  should not be reached
gnome-session[4013]: WARNING: Application 'gnome-shell.desktop' killed by signal 6
gnome-session[4013]: WARNING: App 'gnome-shell.desktop' respawning too quickly


and then some GLib-CRITICAL errors - do you need these too?
Comment 2 Need Real Name 2013-05-13 05:16:21 EDT
Open new bug 962351 for new error about wacom.
Comment 3 Adam Williamson 2013-05-14 17:18:59 EDT
Reporter - can you attach the ~/.xsession-errors file , and possibly stuff from /var/log/gdm if it looks interesting? Thanks.
Comment 4 Need Real Name 2013-05-15 05:00:37 EDT
I don't have an ~/.xsession-errors file, but will attach what I have.
Comment 5 Need Real Name 2013-05-15 05:01:05 EDT
Created attachment 748152 [details]
gdm log
Comment 6 Need Real Name 2013-05-15 05:01:54 EDT
Created attachment 748153 [details]
xorg log
Comment 7 Adam Williamson 2013-05-15 10:40:51 EDT
I think we really need xsession-errors :/ Maybe I should be a bit more specific: try to reproduce the problem, so you see the "Oh no!" screen, and at that point switch to a console and look in your home directory for a file .xsession-errors (it is of course a hidden file).

I suppose "Bluetooth:ERROR:rfkill-glib.c:83:type_to_string: code  should not be reached" may be the fatal error here (though I really wanted to see xsession-errors to get more context). Do you have a Bluetooth adapter? If so, can it be disabled or removed? Does that work around the problem? Thanks!
Comment 8 Need Real Name 2013-05-15 13:24:34 EDT
There really is no ~/.xsession-errors, which is admittedly odd.

What if I were to run
 xinit
then run
 gnome-session
from the terminal, and give you the output from that?

I will try disabling bluetooth in the bios. If that fails I will rmmod it.
Comment 9 Adam Williamson 2013-05-15 13:32:14 EDT
You could try 'journalctl -a', that may have the info.
Comment 10 Need Real Name 2013-05-16 03:27:47 EDT
Created attachment 748626 [details]
journalctl -abf --lines=0
Comment 11 Need Real Name 2013-05-16 03:30:31 EDT
I blacklisted bluetooth and rebooted. That log shows everything from when I killed gdm onwards.
Comment 12 Need Real Name 2013-05-16 04:23:48 EDT
I ran a yum remove colord, then I ran yum install colord. No change.
Comment 13 Adam Williamson 2013-05-16 12:14:42 EDT
Does it work if you boot with "enforcing=0"?
Comment 14 Need Real Name 2013-05-16 16:20:04 EDT
I will try. There is nothing in the audit log, and setenforce 0 beforehand doesn't help.
Comment 15 Need Real Name 2013-05-17 04:47:41 EDT
btw deleting the ~/.xsession-errors on other computers also seems to prevent it from ever being created again.
Comment 16 Need Real Name 2013-05-17 05:04:31 EDT
enforcing=0 does not help. I have new logs, I'll post them.
Comment 17 Need Real Name 2013-05-17 05:05:24 EDT
Created attachment 749260 [details]
gdm log :0.log
Comment 18 Need Real Name 2013-05-17 05:14:19 EDT
Created attachment 749261 [details]
xorg :0.log
Comment 19 Need Real Name 2013-05-17 05:15:07 EDT
Created attachment 749262 [details]
xorg :0.log.1
Comment 20 Adam Williamson 2013-05-17 12:15:22 EDT
There's nothing much in there, the journalctl seemed like the interesting thing. I guess the bluetooth error is still our main suspect. Can you attach the latest journalctl? But I think we need Ray or another of the GNOME folks to look through the logs and figure out what's going on here.
Comment 21 Need Real Name 2013-05-17 17:46:12 EDT
I will attach the latest journalctl on Tuesday morning.
Comment 22 Need Real Name 2013-05-17 17:52:21 EDT
btw I have bug 962351 open for the wacom critical error.

Reinstalling colord does not help the "Error creating directory: Permission denied" error.

I can do nothing about the tracker error, it has too many dependencies to remove and forcing it prevents gnome from working.

bluetooth is currently blacklisted.

yum check reveals no problems.
Comment 23 Need Real Name 2013-05-21 05:06:38 EDT
Created attachment 750913 [details]
journalctl
Comment 24 Need Real Name 2013-05-27 07:11:12 EDT
Just tried to install Fedora 19 beta RC4, and the installer crashed with the same problem.

Unfortunately I didn't capture the log files since there was not enough time.
Comment 25 Need Real Name 2013-05-29 03:39:49 EDT
The logs at /tmp/*log do not capture any information related to the gnome crash.

What do you want me to do? That was a fresh install attempt.
Comment 26 Adam Williamson 2013-05-29 12:37:50 EDT
Still waiting for the GNOME devs to take a look, I'm afraid :( I can't get a lot further with this one.
Comment 27 Kalev Lember 2013-05-31 18:55:20 EDT
It's a crash (assert) in the rfkill handling code.

kernel 3.9 added some new RFKILL_TYPE enum types, but gnome-bluetooth's rfkill code only handles the older types. There's a changeset in git that fixes this; I'll ask hadess on Monday if we can have a new gnome-bluetooth release.


P.S. I'm mildly annoyed by the aggressive kernel updates in older releases. Looks like F17 is getting kernel 3.9 as well and we'll have to patch at least gnome-bluetooth and control-center to fix crashes with the new kernel version.
Comment 28 Adam Williamson 2013-05-31 19:19:31 EDT
Doesn't the upstream kernel have a stated policy that 'if something worked with an older kernel and doesn't work now, that's a kernel bug'? anyhow. https://fedoraproject.org/wiki/KernelRebases explains the thinking behind rebasing the kernels of stable releases; it kinda makes sense to me, though sometimes it does cause inconvenience.

This seems like something we'd definitely want fixed ahead of 19 release, and backported to 17 and 18...
Comment 29 Marco Coli 2013-06-02 08:48:23 EDT
Same problem here with hp8510w notebook. Crash with gnome ad cinnamon after f19 upgrade, Ok with lxde
Comment 30 FireWave 2013-06-02 22:49:12 EDT
Same problem here, with gnome-shell. journalctl -ba shows the bluetooth error. HP8530w
Comment 31 Raoul Thill 2013-06-03 05:11:59 EDT
Same problem here on HP6730b notebook
Comment 32 Fedora Update System 2013-06-03 09:28:04 EDT
gnome-bluetooth-3.8.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-bluetooth-3.8.1-1.fc19
Comment 33 Raoul Thill 2013-06-03 09:47:40 EDT
The package gnome-bluetooth-3.8.1-1.fc19 fixed my problem.

Thanks!
Comment 34 Need Real Name 2013-06-03 11:12:28 EDT
Won't be able to test until end of week.

btw I'm going to use this bug as an example whenever I'm told that because nobody else is having the problem, I must be the only one - twenty two days until a confirmed report (thanks Kalev Lember)
Comment 35 Adam Williamson 2013-06-03 12:00:19 EDT
I don't think anyone said that in this case.
Comment 36 Adam Williamson 2013-06-03 12:01:58 EDT
Throw this on the final blocker list just to be safe, conditional violation of https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Expected_installed_system_boot_behavior for affected systems (looks to be various HP laptops).
Comment 37 Kalev Lember 2013-06-03 16:46:24 EDT
(In reply to Adam Williamson from comment #28)
> This seems like something we'd definitely want fixed ahead of 19 release,
> and backported to 17 and 18...

F18 already has the fix in stable updates, and here's the F17 update:

https://admin.fedoraproject.org/updates/gnome-bluetooth-3.4.2-2.fc17
Comment 38 Adam Williamson 2013-06-03 17:28:03 EDT
Awesome. I'll try and get the f17 update some karma. Thanks.
Comment 39 Marco Coli 2013-06-04 09:54:13 EDT
ok for me too (hp 8510w) after upgrade. Thank you
I had to manually download and install the package from the link provided above, because yum (even after yum clean all) did not find this specific upgrade (only others)
Comment 40 Adam Williamson 2013-06-04 11:33:56 EDT
It takes a bit of time for a newly-submitted update to actually appear in a tree compose and then make its way out to the mirrors. As long as the upgrade worked for you, that's great: can you add karma to it? See https://fedoraproject.org/wiki/QA:Updates_Testing for details. Thanks!
Comment 41 Fedora Update System 2013-06-04 22:33:51 EDT
Package gnome-bluetooth-3.8.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-bluetooth-3.8.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10044/gnome-bluetooth-3.8.1-1.fc19
then log in and leave karma (feedback).
Comment 42 Marco Coli 2013-06-05 08:46:21 EDT
karma added.
Comment 43 Adam Williamson 2013-06-05 13:07:32 EDT
Discussed at 2013-06-05 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-05/f19final-blocker-review-3.2013-06-05-16.05.log.txt .  Accepted as a blocker per https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Expected_installed_system_boot_behavior :

"After firstboot is completed and on subsequent boots, a graphical install must boot to a log in screen where it is possible to log in to a working desktop as the user created during firstboot. "

in the case that you have affected hardware (of which there seems to be quite a lot).
Comment 44 Fedora Update System 2013-06-05 22:26:58 EDT
gnome-bluetooth-3.8.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.