Bug 961503 - smsd fails to start with default configuration
smsd fails to start with default configuration
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smstools (Show other bugs)
18
All All
unspecified Severity low
: ---
: ---
Assigned To: Patrick C. F. Ernzer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 14:35 EDT by Kaarle Ritvanen
Modified: 2013-06-07 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: smstools-3.1.15-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 19:52:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested correction (2.63 KB, patch)
2013-05-09 14:35 EDT, Kaarle Ritvanen
no flags Details | Diff

  None (edit)
Description Kaarle Ritvanen 2013-05-09 14:35:43 EDT
Created attachment 745770 [details]
Suggested correction

Description of problem:
smsd fails to start with default configuration because the smstool user lacks permissions to create pidfile and infofile into /run.

Version-Release number of selected component (if applicable):
3.1.15-2

Steps to Reproduce:
1. yum install smstools
2. systemctl start smsd
  
Actual results:
smsd fails to start

Expected results:
smsd starts properly

Additional info:
Suggested correction attached. It uses the tmpfiles mechanism to create a new directory, /run/smsd, with write permissions for the smstools user. Creating the files directly into /run does not work well because smsd unlinks the files upon exit.
Comment 1 Fedora Update System 2013-05-23 10:15:15 EDT
smstools-3.1.15-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/smstools-3.1.15-6.fc19
Comment 2 Patrick C. F. Ernzer 2013-05-23 10:25:47 EDT
Kiitos Kaarle,

I've pushed this to rawhide, F19 and F18.

PCFE
Comment 3 Fedora Update System 2013-05-23 10:33:17 EDT
smstools-3.1.15-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/smstools-3.1.15-6.fc18
Comment 4 Fedora Update System 2013-05-25 08:17:44 EDT
Package smstools-3.1.15-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing smstools-3.1.15-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9185/smstools-3.1.15-6.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-07 19:52:01 EDT
smstools-3.1.15-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-06-07 23:32:42 EDT
smstools-3.1.15-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.