Bug 961509 - "realm join" not automatically installing winbind packages
"realm join" not automatically installing winbind packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 15:04 EDT by yelley
Modified: 2014-09-14 20:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 11:38:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yelley 2013-05-09 15:04:00 EDT
Description of problem:

If the required winbind packages are not installed, then running "realm join" with '--client-software=winbind" does not automatically install them. 

When run in verbose mode, the output ends with "Successfully enrolled machine in realm". However, the output also shows that realmd is neither able to start the winbind service, nor able to enable winbind using authconfig (b/c the packages aren't installed, and so relevant files can't be found).

Note that "realm join" works properly after manually installing the missing required-packages (samba-winbind and samba-winbind-clients)

Note also that there is no custom /etc/realmd.conf file, and that "realm join" has no problem automatically installed sssd packages.

Version-Release number of selected component (if applicable):
realmd-0.14.0-1

Steps to Reproduce:
$ rpm -qa | grep winbind       // no winbind packages installed
$ sudo realm join -v --client-software=winbind --user=Administrator foo.com
Password for Administrator
 * Resolving: _ldap._tcp.dc._msdcs.foo.com
 * Sending MS-CLDAP ping to: 10.16.189.20
 * Successfully discovered: foo.com
 * Required files: /usr/bin/wbinfo, /usr/sbin/winbindd, /usr/bin/net
 * LANG=C LOGNAME=root /usr/bin/net -s /var/cache/realmd/realmd-smb-conf.A63SWW -U Administrator ads join foo.com
Enter Administrator's password:
DNS update failed: NT_STATUS_INVALID_PARAMETER
Using short domain name -- FOO
Joined 'F19-CLIENT' to dns domain 'foo.com'
No DNS domain configured for f19-client. Unable to perform DNS Update.
 * LANG=C LOGNAME=root /usr/bin/net -s /var/cache/realmd/realmd-smb-conf.A63SWW -U Administrator ads keytab create
Enter Administrator's password:
 * /usr/bin/systemctl enable winbind.service
Failed to issue method call: No such file or directory
 * /usr/bin/systemctl restart winbind.service
Failed to issue method call: Unit winbind.service failed to load: No such file or directory. See system logs and 'systemctl status winbind.service' for details.
 * /usr/sbin/authconfig --update --enablewinbind --enablewinbindauth --enablemkhomedir --nostart
authconfig: Authentication module /lib64/security/pam_winbind.so is missing. Authentication process might not work correctly.
 * Successfully enrolled machine in realm

Expected results:
"realm join" should automatically install the required winbind packages (if they are not already installed).
Comment 1 Stef Walter 2013-05-13 01:00:39 EDT
Looks like we need to add 'samba-winbind-clients' which was split out from 'samba-winbind' in f19.
Comment 2 Stef Walter 2013-05-13 06:59:32 EDT
Hmmm, we do have samba-winbind-clients. Have you manually installed samba or manually installed /usr/bin/wbinfo? This file is used to (pre)check the presence of samba-winbind-clients.

I see the following when doing discovery on a winbind domain:

radi08.segad.lab.sjc.redhat.com
  type: kerberos
  realm-name: RADI08.SEGAD.LAB.SJC.REDHAT.COM
  domain-name: radi08.segad.lab.sjc.redhat.com
  configured: no
  server-software: active-directory
  client-software: winbind
  required-package: samba-winbind-clients
  required-package: samba-winbind
  required-package: samba-common

Do you see the same thing?

Could you run this?

$ rpm -ql samba-winbind-clients
Comment 3 yelley 2013-05-13 09:30:45 EDT
I see the same output as you do when doing discovery on a winbind domain; "rpm -ql samba-winbind-clients" includes /usr/bin/wbinfo.

Actually, for some reason, I am no longer able to reproduce this bug. Everything is working fine now. Perhaps my environment had been corrupted somehow by my samba debugging work. I no longer think this is a bug.
Comment 4 Stef Walter 2013-05-13 11:38:45 EDT
Alright. Thanks for checking.

Note You need to log in before you can comment on or make changes to this bug.