Bug 961514 - Teach rhc snapshot to rename-on-restore to facilitate gear migrations
Teach rhc snapshot to rename-on-restore to facilitate gear migrations
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 15:20 EDT by Sumana Annam
Modified: 2015-05-14 19:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 18:57:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sumana Annam 2013-05-09 15:20:19 EDT
Description of problem:

https://www.openshift.com/content/teach-rhc-snapshot-to-rename-on-restore-to-facilitate-gear-migrations

This came up when reading through https://www.openshift.com/kb/kb-e1052-ho-do-i-migrate-my-app

If that article is indeed still accurate...rhc snapshot restore would have to be taught how to rename an app, to facilitate a migration workflow (since we'd otherwise have a app name collision).

Side note...It would be nice if openshift didn't require a full gear outage/delete for a gear-size or gear-to-gear migrations. It means there is currently no way to really test a restore without deleting your site first.

I had a problem on restore recently...the restore worked fine, but I think either the snapshot didn't grab themes or plugins or something else (file permissions? Wordpress bug? ...didn't troubleshoot much as I was scrambling to fix it).

Anyway, it would have been nice to catch this before it took my site down by doing a test restore.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Clayton Coleman 2013-05-10 12:16:36 EDT
Node is the only one who can do this.
Comment 2 Jhon Honce 2013-05-10 14:44:04 EDT
It's not clear to me there is a bug report here, there are a number of enhancements requests.  Yes? 

/jwh
Comment 3 Sumana Annam 2013-05-17 13:08:44 EDT
yes - can you move it to trello?

thanks
Comment 5 Jhon Honce 2013-08-14 18:57:27 EDT
Details on feature request can be tracked at https://trello.com/c/j6rvqaEd/234-rhc-snapshot-restore-should-support-application-rename
Comment 6 Gerrit Hübbers 2013-08-16 16:24:08 EDT
UPSTREAM -> WONTFIX? So does this mean this feature is no longer considered? If this is the case, can you give insight why so?
Comment 7 Xiaoli Tian 2013-08-16 22:08:43 EDT
I guess the feature about snapshot restore to a new different app name application  is already supported  in current environment.

Note You need to log in before you can comment on or make changes to this bug.