Bug 961516 - [abrt] BUG: sleeping function called from invalid context at kernel/mutex.c:413
[abrt] BUG: sleeping function called from invalid context at kernel/mutex.c:413
Status: CLOSED DUPLICATE of bug 958935
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:1d7e0f8a75f3923048185abe936...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 15:32 EDT by Nicolas Mailhot
Modified: 2013-05-13 21:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 21:40:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (254.24 KB, text/plain)
2013-05-09 15:32 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2013-05-09 15:32:20 EDT
Additional info:
BUG: sleeping function called from invalid context at kernel/mutex.c:413
in_atomic(): 1, irqs_disabled(): 1, pid: 714, name: Xorg
INFO: lockdep is turned off.
irq event stamp: 638208
hardirqs last  enabled at (638207): [<ffffffff81721116>] _raw_spin_unlock_irqrestore+0x36/0x70
hardirqs last disabled at (638208): [<ffffffff81720fdf>] _raw_spin_lock_irq+0x1f/0x90
softirqs last  enabled at (638184): [<ffffffff81609f51>] netlink_poll+0x141/0x1e0
softirqs last disabled at (638182): [<ffffffff81720e58>] _raw_spin_lock_bh+0x18/0x80
CPU: 0 PID: 714 Comm: Xorg Not tainted 3.10.0-0.rc0.git21.1.fc20.x86_64 #1
Hardware name: Gigabyte Technology Co., Ltd. EP45-DS5/EP45-DS5, BIOS F12 09/30/2008
 ffffffff81a1c03d ffff880121d8fc60 ffffffff817195cb ffff880121d8fc88
 ffffffff810a32d9 0000000000000000 ffff880122b94000 ffff88010a01cdc0
 ffff880121d8fd10 ffffffff8171d95b ffff880073948357 ffff880121d8fd00
Call Trace:
 [<ffffffff817195cb>] dump_stack+0x19/0x1b
 [<ffffffff810a32d9>] __might_sleep+0x179/0x230
 [<ffffffff8171d95b>] mutex_lock_nested+0x3b/0x400
 [<ffffffff8135f70c>] ? vsnprintf+0x20c/0x670
 [<ffffffff81590f27>] hid_debug_event+0x37/0x100
 [<ffffffff8159113c>] hid_dump_input+0x5c/0x90
 [<ffffffff815921b1>] hid_set_field+0x41/0x110
 [<ffffffff815a0053>] usb_hidinput_input_event+0x93/0x110
 [<ffffffff8153761e>] input_handle_event+0x8e/0x530
 [<ffffffff81537ce0>] input_inject_event+0x1b0/0x250
 [<ffffffff81537b73>] ? input_inject_event+0x43/0x250
 [<ffffffff8153bf7f>] evdev_write+0xef/0x150
 [<ffffffff811dcbe0>] vfs_write+0xc0/0x1f0
 [<ffffffff811fbaa9>] ? fget_light+0xf9/0x510
 [<ffffffff811dd59c>] SyS_write+0x4c/0xa0
 [<ffffffff8172ad99>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 959801
Comment 1 Nicolas Mailhot 2013-05-09 15:32:27 EDT
Created attachment 745802 [details]
File: dmesg
Comment 2 Nikola Pajkovsky 2013-05-13 21:40:03 EDT

*** This bug has been marked as a duplicate of bug 958935 ***

Note You need to log in before you can comment on or make changes to this bug.