Bug 961532 - [RFE] Update storage domain's LUNs sizes in DB after lun resize
[RFE] Update storage domain's LUNs sizes in DB after lun resize
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Daniel Erez
Elad
storage
: FutureFeature
Depends On:
Blocks: 1053890
  Show dependency treegraph
 
Reported: 2013-05-09 16:29 EDT by Dax Kelson
Modified: 2014-04-14 06:03 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1053890 (view as bug list)
Environment:
Last Closed: 2014-03-31 11:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22887 None None None Never

  None (edit)
Description Dax Kelson 2013-05-09 16:29:32 EDT
Description of problem:

I setup an iSCSI storage domain with a LUN that was too small. After I resized the LUN on the storage array, ovirt still saw the original size.

I got a command line on the node running spm, and tried running pvresize to no avail.

I ended up doing low level hacking by attaching to the VG group from another Linux box and running pvresize, then rebooting all my nodes.

This needs to be handled much more gracefully and from the UI.
Comment 1 Jiri Vitek 2013-09-17 12:29:06 EDT
This feature will be very welcome, i was asking on same in very first 3.0 release
Comment 2 Juan Pablo Lorier 2013-11-20 06:38:01 EST
Hi,

Same situation. I need to enlarge my iscsi LUN, peace of cake by the linux side but had no solution from within ovirt.
I had set the SD to mantainance and back to active as suggested in the list, but it didn't work. Also tried force a SPM reelection as another suggested and it didn't work either.
I shouldn't be that hard to recheck the size of the SD once you re activate it (at least)
Comment 3 Ayal Baron 2013-11-21 08:35:16 EST
(In reply to Juan Pablo Lorier from comment #2)
> Hi,
> 
> Same situation. I need to enlarge my iscsi LUN, peace of cake by the linux
> side but had no solution from within ovirt.
> I had set the SD to mantainance and back to active as suggested in the list,
> but it didn't work. Also tried force a SPM reelection as another suggested
> and it didn't work either.
> I shouldn't be that hard to recheck the size of the SD once you re activate
> it (at least)

Ack, we're already pulling the data from the spm when activating so it should just be a matter of updating the info in the db.
Daniel, let's track that change here.
Comment 4 Jiri Vitek 2013-11-21 10:41:22 EST
please keep on mind features like netapp volume/lun autogrow
Comment 5 Daniel Erez 2014-01-01 09:15:08 EST
According to the suggestion solution, added LUN device size synchronization as part of storage domain activation. I.e. when activating an iSCSI storage domain, device size mismatch is detected and updated accordingly in the DB.
Comment 6 Allon Mureinik 2014-01-13 12:03:40 EST
In order to make the scope of this RFE clear, it only handles resizing a LUN that is part of storage domain.

Handling direct LUNs should be tracked in a different BZ.
Comment 7 Sandro Bonazzola 2014-02-07 06:20:02 EST
Fixes should be in ovirt-3.4.0-beta2. Assignee please check.
Comment 8 Aharon Canan 2014-02-26 06:47:24 EST
executed upstream , working fine
https://tcms.engineering.redhat.com/run/114786/
Comment 9 Sandro Bonazzola 2014-03-31 11:04:42 EDT
This is an automated message: moving to Closed CURRENT_RELEASE since oVirt 3.4.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.