Bug 961549 - [abrt] dnf-0.3.4-1.git03fd687.fc19: __init__.py:826:perform:Exception: (10, 'Error HTTP/FTP status code: 404', 404)
Summary: [abrt] dnf-0.3.4-1.git03fd687.fc19: __init__.py:826:perform:Exception: (10, '...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:dfc74c16e39689d7cfd936919b4...
Keywords:
: 963218 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-09 22:34 UTC by Hein Kerstgens
Modified: 2014-09-30 23:41 UTC (History)
3 users (show)

Fixed In Version: dnf-0.3.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 08:53:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.42 KB, text/plain)
2013-05-09 22:34 UTC, Hein Kerstgens
no flags Details
File: core_backtrace (1.01 KB, text/plain)
2013-05-09 22:34 UTC, Hein Kerstgens
no flags Details
File: environ (114 bytes, text/plain)
2013-05-09 22:34 UTC, Hein Kerstgens
no flags Details

Description Hein Kerstgens 2013-05-09 22:34:40 UTC
Version-Release number of selected component:
dnf-0.3.4-1.git03fd687.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
dso_list:       python-librepo-0.0.4-1.fc19.x86_64
executable:     /usr/bin/dnf
kernel:         3.9.0-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
__init__.py:826:perform:Exception: (10, 'Error HTTP/FTP status code: 404', 404)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 303, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 131, in main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1371, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 1002, in doCommand
    self.base.activate_sack() # performs the md sync
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 189, in activate_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 123, in _add_repo_to_sack
    repo.load()
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 347, in load
    if self._try_revive():
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 256, in _try_revive
    handle.perform()
  File "/usr/lib64/python2.7/site-packages/librepo/__init__.py", line 826, in perform
    _librepo.Handle.perform(self, result)
Exception: (10, 'Error HTTP/FTP status code: 404', 404)

Local variables in innermost frame:
self: <dnf.repo._Handle object at 0x298caa0>
result: <librepo.Result object at 0x29a8128>

Comment 1 Hein Kerstgens 2013-05-09 22:34:45 UTC
Created attachment 745832 [details]
File: backtrace

Comment 2 Hein Kerstgens 2013-05-09 22:34:51 UTC
Created attachment 745833 [details]
File: core_backtrace

Comment 3 Hein Kerstgens 2013-05-09 22:34:53 UTC
Created attachment 745834 [details]
File: environ

Comment 4 Ales Kozumplik 2013-05-10 05:55:26 UTC
Hi, thanks for the report. Seems like there's a handler missing for a librepo exception.

Comment 5 Ales Kozumplik 2013-05-10 07:09:02 UTC
Addressed by master branch commit 91bd600. The fix will be included in dnf-0.3.5.

Comment 6 Ales Kozumplik 2013-05-16 05:31:07 UTC
*** Bug 963218 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.