Bug 961590 - orgs newly created in katello do not appear in "Any Context" filtering
orgs newly created in katello do not appear in "Any Context" filtering
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Tomas Strachota
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 22:51 EDT by Corey Welton
Modified: 2016-04-22 11:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:23:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 2513 None None None 2016-04-22 11:06 EDT

  None (edit)
Description Corey Welton 2013-05-09 22:51:01 EDT
Description of problem:
When user creates a new org and its environments, if desired, said Org appears in the Hosts > New Hosts UI.  However, if user browses the "Any context" dropdown, new orgs do not appear.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Login to katello+foreman product and create a new org, "Fibble"
2.  Navigate to /foreman 
3.  Hosts > New Host
4.  Click the "Organization" dropdown and note the presence of your newly created org
5.  From the main Foreman UI navbar, choose go to Any Context > Any Organization
6.  View results
  
Actual results:
Only ACME_Corporation appears

Expected results:
Results for all existing and newly created orgs.

Additional info:
Comment 1 Dominic Cleal 2013-05-23 07:31:54 EDT
Merged in 1.2-stable upstream, commit 299e828523913510b832d83328ba0b29ad70075b.

https://github.com/theforeman/foreman/pull/624
Comment 2 Og Maciel 2013-05-28 21:25:09 EDT
I just tried this and though it is true that the new Org does not appear in the Context menu immediately after creation from the Katello side, navigating to Foreman's Dashboard and then back to Context menu showed the new organization. I'd still argue that on dropdown the organizations should be refreshed.

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-40.noarch
* foreman-installer-puppet-concat-0-2.d776701.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10002-40.noarch
* foreman-proxy-1.1.10001-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-7.f5ae2cd.el6sat.noarch
* katello-1.4.2-7.el6sat.noarch
* katello-all-1.4.2-7.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-7.el6sat.noarch
* katello-configure-1.4.3-10.el6sat.noarch
* katello-configure-foreman-1.4.3-10.el6sat.noarch
* katello-foreman-all-1.4.2-7.el6sat.noarch
* katello-glue-candlepin-1.4.2-7.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
* katello-glue-pulp-1.4.2-7.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.12-1.el6sat.noarch
* signo-katello-0.0.12-1.el6sat.noarch
Comment 3 Sam Kottler 2013-05-28 21:27:21 EDT
It seems like that's more of a design thing than fixing this bug. Should we work upstream to figure out a better design for the meny as it gets refreshed?
Comment 4 Og Maciel 2013-05-28 21:28:36 EDT
Yes. Shall we move this to ASSIGNED then and change flags?
Comment 5 Sam Kottler 2013-05-28 21:30:47 EDT
What do you think of marking this issue as resolved and tracking the design process through the upstream (redmine) until it's ready to get cherry-picked?
Comment 6 Og Maciel 2013-05-29 18:16:23 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=968586
Comment 7 Og Maciel 2013-05-29 18:17:11 EDT
Verified.
Comment 8 Mike McCune 2013-07-18 17:23:31 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.