Bug 961618 - FSError: umount failed
FSError: umount failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:dbec32694385df4ab811a8ad3a1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 01:43 EDT by Adam Williamson
Modified: 2015-01-05 15:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-19 15:36:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (18.31 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: backtrace (851 bytes, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: environ (760 bytes, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: lsblk_output (1.98 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: nmcli_dev_list (3.38 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: packaging.log (749.31 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: program.log (43.39 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: storage.log (165.62 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: syslog (70.20 KB, text/plain)
2013-05-10 01:43 EDT, Adam Williamson
no flags Details
File: anaconda-tb (1.16 MB, text/plain)
2013-05-10 01:44 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-05-10 01:43:22 EDT
Description of problem:
Set up a VM with two disks, one containing a single ext4 partition with F19 Beta TC3 DVD iso on it.
Run the installer. Go to Installation Source. Pick the ISO file from the second disk as the installation source.
Go to Installation Destination. Select both disks as install targets.
On Installation Options, go to Reclaim Space. Choose to delete the whole of the second disk.
Return to hub. Installation Destination shows up with an orange triangle. Click on it, crash happens.
The following was filed automatically by anaconda:
anaconda 19.24-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 626, in unmount
    raise FSError("umount failed")
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 792, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 521, in __init__
    device.format.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1169, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 734, in recursiveRemove
    self.destroyDevice(leaf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 372, in _scheduleActions
    self.storage.recursiveRemove(device)
FSError: umount failed

Version-Release number of selected component:
anaconda-19.24-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC3\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC3

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 372, in _scheduleActions
    self.storage.recursiveRemove(device)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 734, in recursiveRemove
    self.destroyDevice(leaf)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1169, in destroyDevice
    self.devicetree.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 521, in __init__
    device.format.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 792, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 626, in unmount
    raise FSError("umount failed")
FSError: umount failed
Comment 1 Adam Williamson 2013-05-10 01:43:25 EDT
Created attachment 745905 [details]
File: anaconda.log
Comment 2 Adam Williamson 2013-05-10 01:43:28 EDT
Created attachment 745906 [details]
File: backtrace
Comment 3 Adam Williamson 2013-05-10 01:43:30 EDT
Created attachment 745907 [details]
File: environ
Comment 4 Adam Williamson 2013-05-10 01:43:36 EDT
Created attachment 745908 [details]
File: ifcfg.log
Comment 5 Adam Williamson 2013-05-10 01:43:38 EDT
Created attachment 745909 [details]
File: lsblk_output
Comment 6 Adam Williamson 2013-05-10 01:43:40 EDT
Created attachment 745910 [details]
File: nmcli_dev_list
Comment 7 Adam Williamson 2013-05-10 01:43:44 EDT
Created attachment 745911 [details]
File: packaging.log
Comment 8 Adam Williamson 2013-05-10 01:43:52 EDT
Created attachment 745912 [details]
File: program.log
Comment 9 Adam Williamson 2013-05-10 01:43:55 EDT
Created attachment 745913 [details]
File: storage.log
Comment 10 Adam Williamson 2013-05-10 01:43:58 EDT
Created attachment 745914 [details]
File: syslog
Comment 11 Adam Williamson 2013-05-10 01:44:03 EDT
Created attachment 745915 [details]
File: anaconda-tb
Comment 12 Adam Williamson 2013-05-10 01:44:41 EDT
I think Installation Destination should not allow you to select a disk you've already set as the Installation Source as a target disk.
Comment 13 Adam Williamson 2013-06-13 18:57:01 EDT
This is still reproducible with 19.30.5. bcl thought it may be improved by a patch that should help various umount bugs, but apparently not. This is a complex case, though, so it doesn't mean the patch is useless.
Comment 14 David Shea 2014-12-08 17:21:46 EST
Is this issue still reproducable with F21?
Comment 15 Adam Williamson 2015-01-05 15:23:56 EST
For the record, this seems to be fixed with 21 at least. You can't delete the partition. You can 'delete' the disk (which usually sets all partitions on the disk to be deleted), which is a bit weird when the *only* partition on the disk will not in fact be deleted, but that's a very minor cosmetic niggle. changing resolution.

Note You need to log in before you can comment on or make changes to this bug.