Bug 961626 - No supported archive manager found - but xarchiver and file-roller are installed
No supported archive manager found - but xarchiver and file-roller are installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunar-archive-plugin (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 02:01 EDT by Heiko Adams
Modified: 2013-05-14 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: thunar-archive-plugin-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 00:46:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 10075 None None None Never

  None (edit)
Description Heiko Adams 2013-05-10 02:01:18 EDT
Description of problem:
It looks like the plugin is broken at least since the last Thunar update. Everytime I try to extract an archive by using "Extract here" the plugin claims no supported archive manager is found but xarchiver and file-roller are installed on my box.

Version-Release number of selected component (if applicable):
Thunar-1.6.3-1.fc19.x86_64
thunar-archive-plugin-0.3.0-5.fc19.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Open Thunar
2. Select an archive file
3. Open the contextmenu and choose "Extract here"
  
Actual results:
An error message "No supported archive manager found" pops up

Expected results:
The archive should be extracted

Additional info:
Comment 1 Christoph Wickert 2013-05-10 05:36:55 EDT
Thanks for reporting this bug. I knew it was going to happen, but I forgot about it. It's caused by https://fedorahosted.org/fesco/ticket/1077

mv /usr/libexec/thunar-archive-plugin/gnome-file-roller.tap \
  /usr/thunar-archive-plugin/file-roller.tap
mv /usr/libexec/thunar-archive-plugin/fedora-archiver.tap \
  /usr/thunar-archive-plugin/xarchiver.tap
Comment 2 Christoph Wickert 2013-05-10 05:43:52 EDT
This bug does by no means have a "high" severity because it does not result in data loss etc. Please be so kind as to read the Bugzilla documentation at https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity
Comment 3 Fedora Update System 2013-05-10 09:31:18 EDT
thunar-archive-plugin-0.3.0-6.fc19,xarchiver-0.5.2-17.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/thunar-archive-plugin-0.3.0-6.fc19,xarchiver-0.5.2-17.fc19
Comment 4 Fedora Update System 2013-05-10 22:36:45 EDT
Package thunar-archive-plugin-0.3.0-6.fc19, xarchiver-0.5.2-17.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thunar-archive-plugin-0.3.0-6.fc19 xarchiver-0.5.2-17.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7891/thunar-archive-plugin-0.3.0-6.fc19,xarchiver-0.5.2-17.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-05-12 13:51:28 EDT
Package thunar-archive-plugin-0.3.1-1.fc19, xarchiver-0.5.2-17.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thunar-archive-plugin-0.3.1-1.fc19 xarchiver-0.5.2-17.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7891/thunar-archive-plugin-0.3.1-1.fc19,xarchiver-0.5.2-17.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-05-14 00:46:09 EDT
thunar-archive-plugin-0.3.1-1.fc19, xarchiver-0.5.2-17.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.