Bug 961648 - user(s) processes are not moved into the group at login time + cgred restart segfault
user(s) processes are not moved into the group at login time + cgred restart ...
Status: CLOSED DUPLICATE of bug 961646
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.4
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Peter Schiffer
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 03:37 EDT by lejeczek
Modified: 2013-05-17 11:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 11:48:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2013-05-10 03:37:32 EDT
Description of problem:

it seems cgred service starts at boot but each subsequent restart results in segfault
also, more! importantly processes initiated by a user declared in rules are not being acted upon when user logins in

Version-Release number of selected component (if applicable):

libcgroup-0.37-7.el6.x86_64
pam-1.1.1-13.el6.x86_64
2.6.32-358.2.1.el6.x86_64

How reproducible:

mount {
  cpu = /cgroup/cpu;
  cpuset  = /cgroup/cpuset;
  cpuacct = /cgroup/cpuacct;
  memory  = /cgroup/memory;
  devices = /cgroup/devices;
  freezer = /cgroup/freezer;
  net_cls = /cgroup/net_cls;
  blkio = /cgroup/blkio;
}

group . {
  perm {
    task {
      uid = root;
      gid = root;
    }
    admin {
      uid = root;
      gid = root;
    }
  }
}

group limit {
  memory {
    memory.limit_in_bytes = 15G;
  }
  cpuset {
    cpuset.cpus = "5";
    cpuset.mems = 0;
  }
}

and

aUser memory,cpuset  limit/


Steps to Reproduce:
1.
2.
3.
  
Actual results:

declared users are not confined/controlled

Expected results:

when user logs in all processes should be move into the cgroup


Additional info:
Comment 2 Ondrej Vasik 2013-05-17 11:48:48 EDT

*** This bug has been marked as a duplicate of bug 961646 ***

Note You need to log in before you can comment on or make changes to this bug.