Bug 961688 - Scroll wheel doesn't work in Compose
Scroll wheel doesn't work in Compose
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libXi (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 05:35 EDT by Berend De Schouwer
Modified: 2013-08-30 04:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 23:37:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Berend De Schouwer 2013-05-10 05:35:44 EDT
Description of problem:

When replying to mail, the scroll wheel on the mouse doesn't work.  Scrolling received mail with the scroll wheel works.  Scrolling with the keyboard in compose works.

When replying to a message, and quoting that message the scroll wheel does work.

When replying with a blank quote, or deleting the entire quote, the scroll wheel does not work.

Composing a new blank message does allow scrolling.


Version-Release number of selected component (if applicable):

Evolution 3.8.1
evolution-3.8.1-1.fc19.x86_64


How reproducible:

Reply to a message.  Delete the quote (if present.)  Type some text, enough to get a scroll bar.  Scroll with a scroll wheel.


Steps to Reproduce:
1. Receive a mail.
2. Reply to said mail.
3. Delete the entire quote.
4. Type some text (more than the window size)
5. Scroll wheel.
  
Actual results:

6. Message does not scroll.


Expected results:

6. Message scrolls.


Additional info:
Comment 1 Milan Crha 2013-05-13 06:36:03 EDT
Thanks for a bug report. I can reproduce this with gtk3-3.8.1-1.fc19, when I get to a state when the mouse wheel doesn't work, then the only way is to use the wheel when mouse pointer hovers above the scrollbar.

It seems to me like a regression in gtk3, because the same steps work fine with gtk3-3.6.4-1.fc18, with basically the same gtkhtml3 package (4.6.4-1 in Fedora 19 for me).

I'm moving this bug to gtk3, at least to get some explanation what change in there could cause this regression. Note there will be an update for Fedora 19 with 3.8.2 release with this week (most likely), which also includes gtkhtml3-4.6.5. It doesn't include any particular fix for this, but it also doesn't contain any change which would cause this, except of gtk3 version change.
Comment 2 Berend De Schouwer 2013-05-16 05:22:57 EDT
It is indeed still happening.

evolution-3.8.2-1.fc19.x86_64
gtk3-3.8.2-1.fc19.x86_64
gtkhtml3-4.6.5-1.fc19.x86_64
Comment 3 Matthias Clasen 2013-05-24 23:37:40 EDT
this was a bug in libXi that is fixed in current updates
Comment 4 Berend De Schouwer 2013-05-27 07:32:30 EDT
Still a problem with libXi-1.7.1-4.20130524git661c45ca1.fc19 updated today.
Comment 5 John Horne 2013-08-29 11:35:31 EDT
Also still a problem with libXi-1.7.2-1.fc19.x86_64.

Please reopen this bug report.
Comment 6 Milan Crha 2013-08-30 04:12:46 EDT
This [1] is a corresponding upstream bug report. Probably an interesting comment there is [2]. That said, it's not only about libXi, or at least not directly, from my point of view.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=699574
[2] https://bugzilla.gnome.org/show_bug.cgi?id=699574#c16

Note You need to log in before you can comment on or make changes to this bug.