Bug 961719 - SELinux is preventing /usr/sbin/httpd from 'create' accesses on the udp_socket .
SELinux is preventing /usr/sbin/httpd from 'create' accesses on the udp_socket .
Status: CLOSED DUPLICATE of bug 961710
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:611864dce3bb2b825c43d82e814...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 06:54 EDT by Nicolas Mailhot
Modified: 2013-05-10 11:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 11:23:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-10 06:54:55 EDT
Description of problem:
SELinux is preventing /usr/sbin/httpd from 'create' accesses on the udp_socket .

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que httpd devrait être autorisé à accéder create sur  udp_socket par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Objects                 [ udp_socket ]
Source                        httpd
Source Path                   /usr/sbin/httpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           httpd-2.4.4-5.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-08 12:36:01 CEST
Last Seen                     2013-05-10 03:10:01 CEST
Local ID                      fc47821a-a0ac-4e06-8c74-6ef5066f59f2

Raw Audit Messages
type=AVC msg=audit(1368148201.873:9354): avc:  denied  { create } for  pid=1593 comm="httpd" scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tclass=udp_socket


type=SYSCALL msg=audit(1368148201.873:9354): arch=x86_64 syscall=socket success=yes exit=ESRCH a0=a a1=2 a2=0 a3=0 items=0 ppid=1592 pid=1593 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=318 tty=(none) comm=httpd exe=/usr/sbin/httpd subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)

Hash: httpd,certwatch_t,certwatch_t,udp_socket,create

audit2allow

#============= certwatch_t ==============
allow certwatch_t self:udp_socket create;

audit2allow -R
require {
	type certwatch_t;
	class udp_socket create;
}

#============= certwatch_t ==============
allow certwatch_t self:udp_socket create;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git24.1.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-10 11:23:53 EDT

*** This bug has been marked as a duplicate of bug 961710 ***

Note You need to log in before you can comment on or make changes to this bug.