Bug 961781 - Windows resize or new windows get black or transparent [G33 8086:29c2:103c:303b]
Windows resize or new windows get black or transparent [G33 8086:29c2:103c:303b]
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 07:25 EDT by vikram goyal
Modified: 2015-02-17 10:13 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:13:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of the problem (1.07 MB, image/png)
2013-05-10 07:25 EDT, vikram goyal
no flags Details
All Xorg logs (16.86 KB, application/x-bzip)
2013-05-10 07:29 EDT, vikram goyal
no flags Details
screenshot of blacked out or transparent windows (781.23 KB, image/png)
2013-05-11 08:02 EDT, vikram goyal
no flags Details
lsmod output (3.67 KB, text/plain)
2013-05-11 08:02 EDT, vikram goyal
no flags Details
Info as requested (52.29 KB, application/x-bzip)
2013-05-15 03:52 EDT, vikram goyal
no flags Details
Xorg.0.log - X server started without any config file (35.40 KB, text/plain)
2013-09-11 06:23 EDT, vikram goyal
no flags Details
Xorg.0.log - After adding a config file for 'intel' to /etc/X11/xorg.conf.d/ (18.29 KB, text/x-log)
2013-09-11 06:28 EDT, vikram goyal
no flags Details
My screenshot of the problem (810.49 KB, image/png)
2013-09-25 15:10 EDT, jmlevick
no flags Details

  None (edit)
Description vikram goyal 2013-05-10 07:25:49 EDT
Created attachment 746126 [details]
Screen shot of the problem

Description of problem:
This problem started around 1 1/2 months back & I couldn't report it because there was no way, I could capture the screen & show it since all of a sudden all windows when resized or renewed or created are of black colour. Start Menu & konsole start showing up as transparent. & only a logout & relogin will settle the problem & since all windows & menus were either black or transparent, logging out also is not possible.Since ctrl+alt+backspace is also disabled, I had to open a console in ctrl+alt+F<number>, go to root & do init 3 & back to init 5

Since I do not exactly know where is the issue, KDE, Kernel, Xorg, Display Drivers or what, I have just made my best guess.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati.x86_64              7.0.0-0.9.20121015gitbd9e2c064.fc18
xorg-x11-drv-evdev.x86_64            2.7.3-5.fc18             @updates          
xorg-x11-drv-fbdev.x86_64            0.4.3-3.fc18             @anaconda         
xorg-x11-drv-intel.x86_64            2.21.6-1.fc18            @updates          
xorg-x11-drv-mga.x86_64              1.6.2-6.fc18             @updates          
xorg-x11-drv-modesetting.x86_64      0.6.0-1.fc18             @updates          
xorg-x11-drv-nouveau.x86_64          1:1.0.6-4.fc18           @updates          
xorg-x11-drv-openchrome.x86_64       0.3.2-1.fc18             @updates          
xorg-x11-drv-qxl.x86_64              0.0.22-5.20120718gitde6620788.fc18
xorg-x11-drv-synaptics.x86_64        1.6.3-3.fc18             @updates          
xorg-x11-drv-vesa.x86_64             2.3.2-2.fc18             @anaconda         
xorg-x11-drv-vmmouse.x86_64          13.0.0-1.fc18            @updates          
xorg-x11-drv-vmware.x86_64           12.0.2-3.20120718gite5ac80d8f.fc18
xorg-x11-drv-wacom.x86_64            0.16.1-2.fc18            @anaconda         
xorg-x11-font-utils.x86_64           1:7.5-11.fc18            @updates          
xorg-x11-fonts-Type1.noarch          7.5-6.fc18               @fedora           
xorg-x11-proto-devel.noarch          7.6-24.fc18              @fedora           
xorg-x11-server-Xorg.x86_64          1.13.3-3.fc18            @updates          
xorg-x11-server-common.x86_64        1.13.3-3.fc18            @updates          
xorg-x11-server-utils.x86_64         7.5-16.fc18              @updates          
xorg-x11-utils.x86_64                7.5-7.fc18               @anaconda         
xorg-x11-xauth.x86_64                1:1.0.7-2.fc18           @anaconda         
xorg-x11-xinit.x86_64                1.3.2-7.fc18             @anaconda         
xorg-x11-xkb-utils.x86_64            7.7-5.fc18               @updates
kde-runtime-libs.x86_64              4.10.2-1.fc18
running kernel                       3.8.11-200.fc18.x86_64

How reproducible:
It just happens suddenly while working or even if the desktop is idle. No way I could pinpoint what made it happen.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The picture was captured by intuition of the window's buttons. I am attaching all Xorg logs separately. The picture was captured on 09-May-13 13:23 Hours
I couldn't find any .xsession errors file in home directory
Comment 1 vikram goyal 2013-05-10 07:29:28 EDT
Created attachment 746128 [details]
All Xorg logs

I just wanted to emphasize that it happens at least once or twice daily.
Comment 2 vikram goyal 2013-05-11 08:02:07 EDT
Created attachment 746537 [details]
screenshot of blacked out or transparent windows

screenshot of blacked out or transparent windows
Comment 3 vikram goyal 2013-05-11 08:02:57 EDT
Created attachment 746538 [details]
lsmod output

lsmod output
Comment 4 Adam Williamson 2013-05-14 15:12:27 EDT
Can you please add the information specified at https://fedoraproject.org/wiki/How_to_debug_Xorg_problems ? Thanks!
Comment 5 vikram goyal 2013-05-15 03:52:19 EDT
Created attachment 748124 [details]
Info as requested

I have collected almost all info after occurrence of the problem & put it in an archive as attachment.

intel_reg_snapshot > /tmp/snapshot as mentioned in https://fedoraproject.org/wiki/How_to_debug_Xorg_problems hung my box twice & I had to hard reboot it.
So I could not include the output from that.

I also tried running intel_reg_dumper but following was the error message.

[root@mail2 Xorg-bug]# intel_reg_dumper
Gen2/3 Ranges are not supported. Please use unsafe access.Aborted (core dumped)

I could not include i915_error_state since I could not reach that point as the system froze.

Let me know if any more info is required.
Comment 6 vikram goyal 2013-08-20 07:46:47 EDT
Hi,

Its quite sometime since I reported the problem. I have also been updating my system quite regularly but the problem seems to have worsened with time.

These days, it props up at least 5-6 times or more.

Just wondering if it will be solved at all.


Thanks
Comment 7 vikram goyal 2013-09-11 06:18:44 EDT
OK I solved it myself.

I created a config for X11, as under:

[root@mail2 ~]# cat /etc/X11/xorg.conf.d/10-intel.conf 
Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "sna"
EndSection

After doing this, I no longer faced any blacked out or transparent windows.
Comment 8 vikram goyal 2013-09-11 06:23:46 EDT
Created attachment 796330 [details]
Xorg.0.log - X server started without any config file
Comment 9 vikram goyal 2013-09-11 06:28:12 EDT
Created attachment 796333 [details]
Xorg.0.log - After adding a config file for 'intel' to /etc/X11/xorg.conf.d/


after adding configuration instructions to /etc/X11/xorg.conf.d/


[root@mail2 ~]# cat /etc/X11/xorg.conf.d/10-intel.conf 
Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "sna"
EndSection
Comment 10 jmlevick 2013-09-25 15:10:42 EDT
Created attachment 803033 [details]
My screenshot of the problem

Here you can see my screenshot of the problem, also present in GNOME 3
Comment 11 jmlevick 2013-09-25 15:17:22 EDT
I also have this problem, been living with it for a while now... What I don't know is if I have to create a 10-intel.conf as Vikram did to solve it or a 20-intel.conf as the ArchWiki recommends. Also I'm not sure if my card it's compatible with SNA or if I have to set that option to UXA. For the moment, I'll create the same file as Vikram's and test to see if the problem dissapears. In the meantime I'll be waiting for more answers in my #AskFedora question related to this bug:

https://ask.fedoraproject.org/question/32960/black-windows-in-gnome-3-suddenly/

(as it is actually pretty hard to test the solution because I don't know what triggers this problem on the system)

By the way, I'm using Fedora 19 x86_64 with an Intel GMA 3100 (no propietary drivers obviously) and kernel 3.11.1-200.fc19.x86_64. My LSPCI it's available at:

https://gist.github.com/Jmlevick/843bbe330d0e758415ab
Comment 12 Adam Williamson 2013-09-25 18:29:15 EDT
"What I don't know is if I have to create a 10-intel.conf as Vikram did to solve it or a 20-intel.conf as the ArchWiki recommends."

The name of the file is not terribly significant.

All files in that directory ending in '.conf' are read as part of Xorg configuration. The numbering can be used, if you like, to establish an order, if you have multiple snippets and the order in which they will be read is significant.
Comment 13 jmlevick 2013-10-21 01:46:43 EDT
There have been some time since I applied Vikram's workaround to my machine, I can confirm the problem it's fixed with that solution. Already answered the question at askfedora explaining the process:

https://ask.fedoraproject.org/question/32960/black-windows-in-gnome-3-suddenly/

So, should someone mark this bug with another status?
Comment 14 Jiri Popelka 2014-05-22 14:38:46 EDT
I haven't seen the problem on my IBM T43 (Intel 915GM) since using the sna AccelMethod, thanks Vikram.
Comment 15 vikram goyal 2014-07-18 04:00:56 EDT
Glad to help:)
Comment 16 Jean-Philippe GONZALEZ 2014-08-07 05:43:10 EDT
Same problem with IGP of an MSI MS-7529/G31TM-P21 mainboard, after a fresh install and all updates made. Everything is OK, and after some minutes, same blacked out or transparent windows, with GNOME and KDE.

I will try the vikram workaround (thanks a lot), hoping that this bug can be solved with updates for others users.
Comment 17 Fedora End Of Life 2015-01-09 13:06:06 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Fedora End Of Life 2015-02-17 10:13:10 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.