Bug 961799 - OpenShift::NsupdatePlugin::DnsException error is seen when creating app continuously
OpenShift::NsupdatePlugin::DnsException error is seen when creating app conti...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Kubernetes (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 08:22 EDT by Johnny Liu
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 16:15:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2013-05-10 08:22:55 EDT
Description of problem:
Write a while loop to create app continuously, OpenShift::NsupdatePlugin::DnsException error will be thrown out.

Version-Release number of selected component (if applicable):
1.2/2013-05-09.2

How reproducible:
Always

Steps to Reproduce:
1. Write the following script to create app continuously.
#/bin/sh

start=1
end=6000

i=$start
while [ $i -le $end ]; do
    rhc app create app$i jbosseap-6.0 -p redhat -l jialiu@redhat.com
    ret=$?
    if [ X"$ret" != X"0"  ]; then
        break
    fi
    i=$(expr $i + 1)
done
2.
3.
  
Actual results:
Monitor script output till OpenShift::NsupdatePlugin::DnsException error is thrown out.

Expected results:
No such error is seen.

Additional info:
Comment 1 Johnny Liu 2013-05-10 08:24:16 EDT
<--snip-->
rhc app create app85 jbosseap-6.0 -p redhat -l jialiu@redhat.com 
Application Options
-------------------
  Namespace:  jialiu
  Cartridges: jbosseap-6.0
  Gear Size:  default
  Scaling:    no

Creating application 'app85' ... Unable to complete the requested operation due to: uninitialized constant OpenShift::NsupdatePlugin::DnsException.
Reference ID: 10258b13879662f9ff5e54a5d85fe31d
<--snip-->
Comment 3 Brenton Leanhardt 2013-05-10 16:07:50 EDT
Mark, would you mind taking a look at https://github.com/openshift/origin-server/pull/2430 ?

In the meantime, I'll see if I can figure out what the error actually is.
Comment 4 Brenton Leanhardt 2013-05-10 16:11:53 EDT
Actually CC'ing Mark. :)
Comment 5 Brenton Leanhardt 2013-05-15 16:15:51 EDT
I believe the error happens simply because of load.  However the the DnsExeption class was properly renamed to DNSException and fixed in Bug 955602.

*** This bug has been marked as a duplicate of bug 955602 ***
Comment 6 Johnny Liu 2013-05-16 06:25:08 EDT
I found this bug against 1.2/2013-05-09.2 puddle, the DnsExeption indeed is thrown out, maybe upstream has fixed it, but not addressed in 1.2/2013-05-09.2 puddle, so I do not think it should be closed as "DUPLICATE". 

Now I checked 1.2/2013-05-15.1 puddle, the patch is addressed, so I close it as "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.