Bug 961813 - Don't depend on tomcat
Don't depend on tomcat
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 09:27 EDT by Alexander Kurtakov
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 06:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2013-05-10 09:27:00 EDT
Eclipse requires tomcat-el|servlet-api packages we would better switch to the respective glassfish-el|servlet-api packages to reduce our build dependencies.
Comment 1 Krzysztof Daniel 2013-05-14 06:50:21 EDT
Unfortunately this is not possible, because glassfish has different bundle id's for API plugins, and I belive BSN for API bundles should be considered as API. In that light, it is impossible to replace tomcat implementation (to which we add required manifests) with glassfish implementation that provides its own BSN.

Changing glassfish name would cause a BSN conflict (two implementation of one standard with one api, but different content).

I didn't find a way to proceed with this.

Note You need to log in before you can comment on or make changes to this bug.