Bug 961848 - RFE: add support for filtering out agent file transfer messages
RFE: add support for filtering out agent file transfer messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
: FutureFeature
Depends On: 952671
Blocks: 961850
  Show dependency treegraph
 
Reported: 2013-05-10 10:43 EDT by Hans de Goede
Modified: 2013-11-21 02:41 EST (History)
8 users (show)

See Also:
Fixed In Version: spice-server-0.12.4-1.el6
Doc Type: Enhancement
Doc Text:
Feature: Allow disabling agent based file transfer; Reason: Spice now supports copying files from client into guest using spice-vdagent (aka file transfer). By default this feature is enabled. Users may want to disable it. Result (if any): A new disable-agent-file-transfer option for qemu's -spice argument. Spice file-transfer messages are dropped when qemu-kvm (and spice) are given this option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 02:41:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-05-10 10:43:48 EDT
Allow disabling agent based file transfer, just like we allow disabling copy-paste. IOW, add the necessary API to spice-server to implement a new disable-agent-file-transfer option for qemu's -spice argument, so that qemu can be invoked as:
qemu -spice port=5900,disable-agent-file-transfer

And that the agent channel will then filter out file transfer messages.
Comment 2 Hans de Goede 2013-06-06 11:19:43 EDT
Patch posted upstream: http://lists.freedesktop.org/archives/spice-devel/2013-June/013621.html
Comment 5 Hans de Goede 2013-06-24 03:41:58 EDT
This is fixed by this upstream commit: http://cgit.freedesktop.org/spice/spice/commit/?id=db278430f8994fe774beb50397cc935de5f1755f

Re-assigning to Uri for adding this commit to the next spice-server build.
Comment 10 errata-xmlrpc 2013-11-21 02:41:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1571.html

Note You need to log in before you can comment on or make changes to this bug.