Bug 961878 - PRESET: add default on preset for ipmi service and ipmievd service
PRESET: add default on preset for ipmi service and ipmievd service
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PresetChanges
  Show dependency treegraph
 
Reported: 2013-05-10 11:34 EDT by Ales Ledvinka
Modified: 2016-09-20 00:33 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 10:25:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Ledvinka 2013-05-10 11:34:06 EDT
Description of problem:
first/2) ipmi service is calling for a default on preset (ipmi service from from OpenIPMI package) it does module probing/loading. Besides module loading/probing it may be configured beyond default values and will also start ipmi watchdog then.
Details why it does so are referenced from
https://fedorahosted.org/fesco/ticket/1110

second/2) ipmievd service asks for default on preset (ipmievd service from ipmitool package) it depends on ipmi service(modules loaded) and then collects events from autonomous system management board. In some cases of recognized event and error condition this may provide useful log message.
More details in
https://fedorahosted.org/fesco/ticket/1111
Comment 1 Lennart Poettering 2013-05-13 09:11:00 EDT
What's the precise name of the untis to enable?

Can you provide us with a link to the service files in question? Would be nice to have a look.
Comment 2 Ales Ledvinka 2013-05-13 09:13:04 EDT
$ rpm -ql OpenIPMI | grep -e systemd
/usr/lib/systemd/system/ipmi.service
$ rpm -ql ipmitool | grep -e systemd
/usr/lib/systemd/system/ipmievd.service
Comment 3 Lennart Poettering 2013-05-13 15:16:57 EDT
Do you happen to have URL or so where I can find the unit files so I can have a look at them? Thanks!
Comment 5 Jóhann B. Guðmundsson 2013-05-13 15:39:56 EDT
(In reply to comment #1)
> What's the precise name of the untis to enable?
> 
> Can you provide us with a link to the service files in question? Would be
> nice to have a look.

Good that you are looking out to review the unit since fesco is sending mixed signal on their meetings basically like with this I had the notion they kinda denied this but forwarded to us to decide. 

It's like they are avoiding due their civic duties which they got elected for...
Comment 7 Lennart Poettering 2013-09-12 21:31:44 EDT
Changed in F20 fedora git.
Comment 8 Fedora Update System 2013-09-13 12:16:21 EDT
systemd-207-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/systemd-207-1.fc20
Comment 9 Fedora Update System 2013-09-22 20:04:34 EDT
systemd-207-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.