This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 961888 - [ORIGIN]Openshift Console does not set correct SELinux context for /var/www/openshift/console/httpd/run
[ORIGIN]Openshift Console does not set correct SELinux context for /var/www/o...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 12:10 EDT by Jason DeTiberus
Modified: 2013-06-10 23:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 23:56:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-05-10 12:10:32 EDT
Description of problem:
oo-diagnostics throws a warning for incorrect SELinux context on /var/www/openshift/console/httpd/run/httpd.pid.  The context should be httpd_var_run_t and not httpd_sys_rw_content_t

Version-Release number of selected component (if applicable):
1.5.18-1

How reproducible:
Everytime

Steps to Reproduce:
1. Do a new install
2. Run oo-diagnostics
3.
  
Actual results:
Warning for incorrect SELinux context on /var/www/openshift/console/httpd/run/httpd.pid

Expected results:
No warning for SELinux contexts

Additional info:
Comment 1 Jason DeTiberus 2013-05-10 12:36:01 EDT
https://github.com/openshift/origin-server/pull/2425
Comment 2 Jason DeTiberus 2013-05-10 12:39:29 EDT
Since oo-diagnostics is from openshift-extras and mostly enterprise only, here is a better way to reproduce:

Steps to Reproduce:
1. Do a new install
2. ls -Zd /var/www/openshift/console/httpd/run

Actual results:
system_u:object_r:httpd_sys_content_t:s0
 
Expected results:
system_u:object_r:httpd_var_run_t:s0
Comment 3 openshift-github-bot 2013-05-10 19:37:16 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/2ecc9d9c15c6509bb58b352c6b5d991e3c0762cd
<openshift-console> Bug 961888 - Fix SELinux context for httpd run dir

https://bugzilla.redhat.com/show_bug.cgi?id=961888

Sets the proper SELinux context on /var/www/openshift/console/httpd/run
(httpd_var_run_t)
Comment 4 Yujie Zhang 2013-05-21 21:14:48 EDT
Since Jason tested this issue on latest Enterprise Puddle and latest Origin Devenv (RHEL), it is fixed now, so move it to verify, thanks.

Note You need to log in before you can comment on or make changes to this bug.