Bug 961895 - old nvidia card with nouveau driver gives corrupt output on 3.7 and later kernel (with fix)
old nvidia card with nouveau driver gives corrupt output on 3.7 and later ker...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 12:40 EDT by Sjoerd Mullender
Modified: 2013-06-14 07:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 07:53:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the fix for the problem (876 bytes, patch)
2013-05-10 12:40 EDT, Sjoerd Mullender
no flags Details | Diff

  None (edit)
Description Sjoerd Mullender 2013-05-10 12:40:35 EDT
Created attachment 746259 [details]
the fix for the problem

Description of problem:
All 3.7 and 3.8 kernels I have tried make the display of my old laptop unusable.  From the moment the graphics display start, the display is a slowly changing combination of various shades of grey.  There is nothing recognizable on the display.
My nVidia hardware is:
# lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go] (rev a3)

The problem looks a bit like the one described in http://forums.opensuse.org/english/get-technical-help-here/tumbleweed/482510-3-7-2-18-kernel-broken-nvidia-fx5200-latest-tumbleweed-kernel-5.html, and the fix that is referred to in that thread (comment 48) works.  The fix is the following changeset (also attached):

http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=6d175e8f672836711497e9deb0f3cbf77e618aff

I compiled the kernel from the kernel-3.8.11-100.fc17.src.rpm sources but with this patch applied and the result is a display that just works.  The unpatched 3.8.11-100.fc17 kernel does not work.

Version-Release number of selected component (if applicable):
All kernels with version >= 3.7.

How reproducible:
100%

Steps to Reproduce:
1.boot into such a kernel
2.
3.
  
Actual results:
Unusable display.

Expected results:
Usable display.

Additional info:
Earlier I was running Fedora 18 on the laptop.  There the problem was exactly the same, so I was forced to use the latest 3.6 kernel available (from Fedora 17).  I have since reinstalled the laptop with Fedora 17 and have been running the latest 3.6 kernel that I could find (3.6.11-5.fc17).
Comment 1 Josh Boyer 2013-05-28 10:49:28 EDT
That patch went into the upstream tree as commit f6853faa85793bf23b46787e4039824d275453c2 and is contained in the 3.9 kernel release.  F17 currently has 3.9.4 in updates-testing.  Could you please test that kernel and let us know if it works?

https://admin.fedoraproject.org/updates/FEDORA-2013-9123/kernel-3.9.4-100.fc17
Comment 2 Sjoerd Mullender 2013-06-14 03:09:32 EDT
I just came back from vacation, hence the delay in answering.

I upgraded the laptop to Fedora 18 and am running the 3.9.5-201 kernel.  In that kernel the problem is fixed.  None of the unpatched 3.7 or 3.8 kernels I had tried worked.
Comment 3 Josh Boyer 2013-06-14 07:53:30 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.