Bug 961908 - [abrt] realmd-0.14.0-1.fc19: exit: Process /usr/lib64/realmd/realmd was killed by signal 6 (SIGABRT)
[abrt] realmd-0.14.0-1.fc19: exit: Process /usr/lib64/realmd/realmd was kille...
Status: CLOSED DUPLICATE of bug 953486
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
abrt_hash:de92c3502b704cc98c0d7ea23a6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 13:30 EDT by ajs
Modified: 2013-05-13 16:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 16:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.88 KB, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: cgroup (154 bytes, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: core_backtrace (1.21 KB, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: dso_list (4.56 KB, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: environ (92 bytes, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: maps (23.22 KB, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: open_fds (538 bytes, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: proc_pid_status (895 bytes, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details
File: var_log_messages (9.40 KB, text/plain)
2013-05-10 13:30 EDT, ajs
no flags Details

  None (edit)
Description ajs 2013-05-10 13:30:20 EDT
Description of problem:
I was in the middle of performing test 'https://fedoraproject.org/wiki/QA:Testcase_realmd_join_sssd?rd=QA:Testcase_Active_Directory_realmd_join_sssd'

I had just issued 'sudo klist -k'

Version-Release number of selected component:
realmd-0.14.0-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/lib64/realmd/realmd
crash_function: exit
executable:     /usr/lib64/realmd/realmd
kernel:         3.9.1-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (1 frames)
 #9 exit at exit.c:99
Comment 1 ajs 2013-05-10 13:30:23 EDT
Created attachment 746284 [details]
File: backtrace
Comment 2 ajs 2013-05-10 13:30:25 EDT
Created attachment 746285 [details]
File: cgroup
Comment 3 ajs 2013-05-10 13:30:26 EDT
Created attachment 746286 [details]
File: core_backtrace
Comment 4 ajs 2013-05-10 13:30:28 EDT
Created attachment 746287 [details]
File: dso_list
Comment 5 ajs 2013-05-10 13:30:30 EDT
Created attachment 746288 [details]
File: environ
Comment 6 ajs 2013-05-10 13:30:31 EDT
Created attachment 746289 [details]
File: limits
Comment 7 ajs 2013-05-10 13:30:33 EDT
Created attachment 746290 [details]
File: maps
Comment 8 ajs 2013-05-10 13:30:35 EDT
Created attachment 746291 [details]
File: open_fds
Comment 9 ajs 2013-05-10 13:30:37 EDT
Created attachment 746292 [details]
File: proc_pid_status
Comment 10 ajs 2013-05-10 13:30:38 EDT
Created attachment 746293 [details]
File: var_log_messages
Comment 11 Stef Walter 2013-05-13 06:51:09 EDT
This happened when realmd was exiting (due to its timeout). The crash happened in libselinux. realmd makes no explicit selinux calls, and this seems to be some sort of atexit() or dl_fini handler.
Comment 12 Daniel Walsh 2013-05-13 09:54:03 EDT
libselinux has had this behaviour for ever.  Usually when an error happens it is caused by a memory problem.  Basically libselinux at load allocates some memory and at unload frees the memory.  If something in the app has written over memory then it can cause the crash.  Can we run realmd through valgrind to see if it has some memory problems.
Comment 13 Stef Walter 2013-05-13 16:06:02 EDT
Makes sense. Then this is almost certainly a duplicate of bug 953486

*** This bug has been marked as a duplicate of bug 953486 ***

Note You need to log in before you can comment on or make changes to this bug.