Bug 961963 - libint2-debuginfo does not contain sources
libint2-debuginfo does not contain sources
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libint2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2013-05-10 16:37 EDT by Ville Skyttä
Modified: 2013-05-13 06:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 06:33:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-05-10 16:37:09 EDT
libint2-debuginfo 2.0.2-1.615hg does not contain sources. The build log is 358M which will take a long time to download from the slow koji servers so I'll leave finding out why this is to you ($RPM_OPT_FLAGS not being used somewhere where it should, premature stripping or something...?)
Comment 1 Susi Lehtola 2013-05-10 17:19:20 EDT
Opflags *are* used in the build, my guess is that since the library sources are autogenerated by the compiler, normal debuginfo stuff just doesn't work.

There seem to be 1.9GB worth of source files in the build tree.
Comment 2 Susi Lehtola 2013-05-13 06:33:29 EDT
The problem was indeed solved by pregenerating the sources.

Note You need to log in before you can comment on or make changes to this bug.