Bug 961974 - Unable to permanently add port range using firewall-cmd
Unable to permanently add port range using firewall-cmd
Status: CLOSED DUPLICATE of bug 879832
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 17:13 EDT by Krishna Raman
Modified: 2014-06-18 03:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 04:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krishna Raman 2013-05-10 17:13:38 EDT
Description of problem:
Unable to permanently add port range using firewall-cmd

Version-Release number of selected component (if applicable):
Version     : 0.3.2
Release     : 1.fc19

How reproducible:
always

Steps to Reproduce:
1./usr/bin/firewall-cmd --zone=public --list-ports
    35536/tcp 35531-65534/udp 8443/tcp 27017/tcp 8000/tcp 61613/tcp

2./usr/bin/firewall-cmd --zone=public --permanent --add-port=35531-65534/tcp
3./usr/bin/firewall-cmd --zone=public --list-ports

  
Actual results:
    35536/tcp 35531-65534/udp 8443/tcp 27017/tcp 8000/tcp 61613/tcp

Expected results:
    35536/tcp 35531-65534/udp 8443/tcp 27017/tcp 8000/tcp 61613/tcp 35531-65534/tcp


Additional info:
Comment 1 Jiri Popelka 2013-05-10 22:56:27 EDT
(In reply to comment #0)
> 2./usr/bin/firewall-cmd --zone=public --permanent --add-port=35531-65534/tcp

With --permanent you basically just change the stored configuration.
You don't change the runtime configuration.
If you want this change to become active immediately you either have to
change it also in runtime configuration with:
firewall-cmd --zone=public --add-port=35531-65534/tcp
or reload the stored configuration with:
'firewall-cmd --reload'

> 3./usr/bin/firewall-cmd --zone=public --list-ports

Does it show the port range when you do one of the steps mentioned above ?
Comment 2 Jiri Popelka 2013-05-20 04:55:56 EDT

*** This bug has been marked as a duplicate of bug 879832 ***

Note You need to log in before you can comment on or make changes to this bug.