Bug 962012 - AttributeError: 'NoneType' object has no attribute 'get_selected'
AttributeError: 'NoneType' object has no attribute 'get_selected'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:e139a41887212e7d9dd0e44c783...
:
: 962628 (view as bug list)
Depends On:
Blocks: F19Beta-accepted/F19BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-05-10 19:23 EDT by Flóki Pálsson
Modified: 2013-05-29 22:01 EDT (History)
17 users (show)

See Also:
Fixed In Version: anaconda-19.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 22:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (938.71 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: anaconda.log (6.81 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: backtrace (262 bytes, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: environ (760 bytes, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: lsblk_output (4.36 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: nmcli_dev_list (3.27 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: packaging.log (320.33 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: program.log (91.76 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: storage.log (270.42 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details
File: syslog (106.07 KB, text/plain)
2013-05-10 19:23 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2013-05-10 19:23:07 EDT
Description of problem:
trying to remove from MBR
The following was filed automatically by anaconda:
anaconda 19.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 1 Flóki Pálsson 2013-05-10 19:23:15 EDT
Created attachment 746428 [details]
File: anaconda-tb
Comment 2 Flóki Pálsson 2013-05-10 19:23:29 EDT
Created attachment 746430 [details]
File: anaconda.log
Comment 3 Flóki Pálsson 2013-05-10 19:23:31 EDT
Created attachment 746431 [details]
File: backtrace
Comment 4 Flóki Pálsson 2013-05-10 19:23:33 EDT
Created attachment 746432 [details]
File: environ
Comment 5 Flóki Pálsson 2013-05-10 19:23:35 EDT
Created attachment 746433 [details]
File: ifcfg.log
Comment 6 Flóki Pálsson 2013-05-10 19:23:37 EDT
Created attachment 746434 [details]
File: lsblk_output
Comment 7 Flóki Pálsson 2013-05-10 19:23:40 EDT
Created attachment 746435 [details]
File: nmcli_dev_list
Comment 8 Flóki Pálsson 2013-05-10 19:23:43 EDT
Created attachment 746436 [details]
File: packaging.log
Comment 9 Flóki Pálsson 2013-05-10 19:23:47 EDT
Created attachment 746437 [details]
File: program.log
Comment 10 Flóki Pálsson 2013-05-10 19:23:52 EDT
Created attachment 746438 [details]
File: storage.log
Comment 11 Flóki Pálsson 2013-05-10 19:23:59 EDT
Created attachment 746439 [details]
File: syslog
Comment 12 John Reiser 2013-05-13 10:50:38 EDT
Description of problem:
Select both harddrives.  Click on "Full disk summary and bootloader".  Click on drive with green check mark (has boot loader).  Click on Remove.

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   root=live:LABEL=LIVE rootfstype=auto ro rd.luks=0 rd.md=0 rd.dm=0 inst.stage2=hd:UUID=C047-E250 cgroup_disable=memory slub_debug=-
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 13 Adam Williamson 2013-05-14 01:22:37 EDT
Description of problem:
F19 Beta TC4 DVD. Boot on a VM with a single disk. Go to Installation Destination. Click "Full disk summary and bootloader...". Click Remove. Crash.

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 14 Adam Williamson 2013-05-14 01:35:43 EDT
Proposing as an FE, crashes are worth fixing, especially in relatively commonly-accessed bits.
Comment 15 Adam Williamson 2013-05-15 19:32:28 EDT
Discussed at 2013-05-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-15/f19beta-blocker-review-6.2013-05-15-16.02.html . Accepted as a freeze exception issue as an easily-encounterable crasher in the installer which may restrict testing coverage.
Comment 16 Igor Gnatenko 2013-05-17 04:25:28 EDT
Description of problem:
Remove bootloader

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 17 Vojtěch Boček 2013-05-17 17:43:59 EDT
Description of problem:
In Anaconda's screen "Install destination", after selecting my disk, I clicked the link in bottom part of the screen called "Full disk summary and bootloader" and selected my disk in the dialog. Clicking button "Remove" then results in this exception.

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 18 Clyde E. Kunkel 2013-05-18 13:23:36 EDT
Description of problem:
After selecting disks and lvm install method and custom, remembered I did not want a bootloader installed.  Clicked add more disks and then clicked the Full disk summary and bootloader button.  clicked remove in the pop-up, nothing happened, so clicked the set as Boot Device button thinking it would toggle, nothing happened, clicked close, nothing happened, sat back and waited and then this error popped up.

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=afbcf488-11c6-4c3c-8c51-f8ef83d1920a selinux=0 BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 19 Brian Lane 2013-05-20 15:50:33 EDT
*** Bug 962628 has been marked as a duplicate of this bug. ***
Comment 20 M. Edward (Ed) Borasky 2013-05-21 00:37:52 EDT
Description of problem:
Trying to install Fedora Jam Nightly. Selected both disks and was trying to change where the bootloader goes when it crashed. Latest 64-bit nightly as of 20 May 2013.

Version-Release number of selected component:
anaconda-19.28-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8 --xdriver=vesa
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-19-Nightly-x86_64-Live-ja rootfstype=auto ro rd.live.image quiet threadirqs rhgb rd.luks=0 rd.md=0 rd.dm=0 xdriver=vesa nomodeset BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.1-301.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 196, in on_set_as_boot_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 21 Martin Kho 2013-05-21 05:24:59 EDT
Description of problem:
Selected second hdd for installation and tried to remove the bootloader installation.

Version-Release number of selected component:
anaconda-19.28-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-19-Beta-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 22 Fedora Update System 2013-05-21 19:34:35 EDT
anaconda-19.29-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.29-1.fc19
Comment 23 Peter Kotvan 2013-05-22 03:59:32 EDT
Description of problem:
1. selected instalation destination
2. added iscsi network disk
3. selected full disk summary and bootloader at the bottom of screen
4. tried to remove iscsi disc from installation destination

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 24 Jeff Bastian 2013-05-22 16:32:12 EDT
Description of problem:
I chose "Full disk summary and bootloader" from the disks screen and tried to remove the bootloader from /dev/sda

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 137, in on_remove_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 25 Adam Williamson 2013-05-22 18:03:09 EDT
Verified fixed in RC3.
Comment 26 Adam Williamson 2013-05-29 22:01:22 EDT
And 19.30 is now stable, so closed.

Note You need to log in before you can comment on or make changes to this bug.