Bug 962014 - [abrt] WARNING: at fs/btrfs/inode.c:2157 record_one_backref+0x2a9/0x430 [btrfs]()
[abrt] WARNING: at fs/btrfs/inode.c:2157 record_one_backref+0x2a9/0x430 [btrf...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
abrt_hash:119f78a051770c35528e8176fd9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 19:39 EDT by Clemens Eisserer
Modified: 2013-06-08 04:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 04:55:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (65.11 KB, text/plain)
2013-05-10 19:39 EDT, Clemens Eisserer
no flags Details
screenshot of issue with 3.10.0-0.rc1.git0.1.fc20.x86_64 (229.90 KB, image/jpeg)
2013-05-16 16:11 EDT, Clemens Eisserer
no flags Details

  None (edit)
Description Clemens Eisserer 2013-05-10 19:39:11 EDT
Description of problem:
executed btrfs filesystem defragment on a single file

Additional info:
reporter:       libreport-2.1.4
WARNING: at fs/btrfs/inode.c:2157 record_one_backref+0x2a9/0x430 [btrfs]()
Hardware name: Latitude E6320
Modules linked in: nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter rfcomm ip6_tables bnep snd_hda_codec_hdmi snd_hda_codec_idt iTCO_wdt iTCO_vendor_support mmc_block dell_wmi sparse_keymap fuse ppdev mperf coretemp kvm_intel kvm dell_laptop arc4 dcdbas iwldvm cdc_mbim mac80211 microcode i2c_i801 cdc_ncm uvcvideo usbnet videobuf2_vmalloc videobuf2_memops iwlwifi btusb videobuf2_core sdhci_pci videodev snd_hda_intel sdhci media mii cdc_wdm bluetooth cdc_acm mmc_core snd_hda_codec cfg80211 snd_hwdep snd_seq lpc_ich snd_seq_device mfd_core snd_pcm rfkill snd_page_alloc wmi snd_timer snd soundcore parport_pc e1000e parport ptp pps_core mei btrfs libcrc32c xor zlib_deflate raid6_pq dm_crypt crc32_pclmul i915 crc32c_intel ghash_clmulni_intel i2c_algo_bit drm_kms_helper drm i2c_core video uinput
Pid: 647, comm: btrfs-endio-wri Not tainted 3.9.1-301.fc19.x86_64 #1
Call Trace:
 [<ffffffff8105cd86>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ce5a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa0185dc9>] record_one_backref+0x2a9/0x430 [btrfs]
 [<ffffffffa0185b20>] ? can_nocow_odirect+0x270/0x270 [btrfs]
 [<ffffffffa01da0c6>] iterate_extent_inodes+0x1e6/0x370 [btrfs]
 [<ffffffffa0185b20>] ? can_nocow_odirect+0x270/0x270 [btrfs]
 [<ffffffffa01da2d7>] iterate_inodes_from_logical+0x87/0xa0 [btrfs]
 [<ffffffffa01838fb>] record_extent_backrefs+0x7b/0xd0 [btrfs]
 [<ffffffffa018e7b6>] btrfs_finish_ordered_io+0x156/0x990 [btrfs]
 [<ffffffffa018f1d5>] finish_ordered_fn+0x15/0x20 [btrfs]
 [<ffffffffa01ae0eb>] worker_loop+0x12b/0x510 [btrfs]
 [<ffffffffa01adfc0>] ? btrfs_queue_worker+0x300/0x300 [btrfs]
 [<ffffffff81080330>] kthread+0xc0/0xd0
 [<ffffffff81080270>] ? insert_kthread_work+0x40/0x40
 [<ffffffff8164da6c>] ret_from_fork+0x7c/0xb0
 [<ffffffff81080270>] ? insert_kthread_work+0x40/0x40
Comment 1 Clemens Eisserer 2013-05-10 19:39:16 EDT
Created attachment 746440 [details]
File: dmesg
Comment 2 Josef Bacik 2013-05-13 10:22:35 EDT
Yeah sorry about that, it's fixed in 3.10-rc1, can you try that kernel and verify that the problem is fixed?
Comment 3 Clemens Eisserer 2013-05-15 04:17:55 EDT
Unfortunately it was a one-timer, subsequent defrag runs with the same kernel didn't result in the any error messages.

Btw do you know wether rc-kernels are available prepackaged for fedora?
Comment 4 Josh Boyer 2013-05-15 08:45:29 EDT
(In reply to comment #3)
> Unfortunately it was a one-timer, subsequent defrag runs with the same
> kernel didn't result in the any error messages.
> 
> Btw do you know wether rc-kernels are available prepackaged for fedora?

http://koji.fedoraproject.org/koji/buildinfo?buildID=418535
Comment 5 Clemens Eisserer 2013-05-16 16:10:02 EDT
Unfortunately 3.10-rc1 didn't fix the issue, it stumbles in btrfs_search_old_slot.
Screenshot attached...
Comment 6 Clemens Eisserer 2013-05-16 16:11:09 EDT
Created attachment 749042 [details]
screenshot of issue with 3.10.0-0.rc1.git0.1.fc20.x86_64
Comment 7 Clemens Eisserer 2013-06-08 04:55:22 EDT
I've moved this report to upstream bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=59451

Note You need to log in before you can comment on or make changes to this bug.