Bug 962022 - At exit from top cursor is not at the bottom in screen
At exit from top cursor is not at the bottom in screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: procps-ng (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 21:23 EDT by Pete Zaitcev
Modified: 2016-01-31 20:58 EST (History)
3 users (show)

See Also:
Fixed In Version: procps-ng-3.3.7-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 13:01:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2013-05-10 21:23:24 EDT
Description of problem:

If exiting from top with q, the cursor does not go to the bottom.

Version-Release number of selected component (if applicable):

procps-ng-3.3.7-3.fc20

How reproducible:

Synchronous

Steps to Reproduce:
1. start screen (this disables screen clearing at exit)
2. run top
3. quit top with q
  
Actual results:

Screen corrupted by shell prompt

Expected results:

Cursor positioned to the bottom line for exit

Additional info:

Started happening in procps-ng-3.3.7-1.fc20
Last known good version procps-ng-3.3.6-4.fc19
Comment 1 Pete Zaitcev 2013-05-10 21:26:30 EDT
This is not a big issue, because the corruption usually ends in the
empty line (but not always).
Comment 2 Jaromír Cápík 2013-05-15 10:27:06 EDT
Hello Pete.

I can reproduce the issue here.
Thanks for reporting this. I'm gonna ask Jim Warner and let you know.

Regards,
Jaromir.
Comment 3 Jaromír Cápík 2013-05-22 11:39:21 EDT
Hi Pete.

Could you please test the latest build? (procps-ng-3.3.7-4.fc20)

Please, let me know.

Thanks and regards,
Jaromir.
Comment 4 Pete Zaitcev 2013-05-22 13:01:48 EDT
Verified fixed. Works under screen and raw gnome-terminal.

Note You need to log in before you can comment on or make changes to this bug.