Bug 962025 - RFE : Testing ( Beta/RC's of Firefox in Rawhide
RFE : Testing ( Beta/RC's of Firefox in Rawhide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 22:10 EDT by Greg`
Modified: 2013-07-24 10:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 10:48:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg` 2013-05-10 22:10:55 EDT
Description of problem: i been thinking, since Rawhide is pretty well much " raw " an testing upcoming features etc, would it also benefit by testing a Beta(rc) of Firefox also instead of using the stable version that the Alpha is using or any other Fedora Version.

as in using Firefox 21 in rawhide
F19 an F18 an F17 uses Firefox20 stable

by rawhide using 21 or whatever version surely there would be a benefit where Bugs would be found an fixed before it went stable/final?

when Firefox21 went final/stable rawhide would then move to Firefox22 when the other Fedora versions only used stable of firefox .

hope that makes sense.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Rawhide would always use the Beta - Release Candidate of Firefox
2.Beta/RC's only get released once a week anyway AFAIK
3.
  
Actual results: Bugs found in Firefox-rawhide would get fixed before it landed on a stable Fedora Release


Expected results: by testing a Beta/RC build of Firefox in Rawhide would also benefit by the time it went stable an gets into the stable Fedora releases


Additional info:
Comment 1 Martin Stransky 2013-07-24 10:48:36 EDT
We have considered it but it will produce extra maintenance cost. Those bug found in Alfa/Beta should be reported directly at bugzilla.mozilla.org and if you're able to report them, it would be easy for you to use an upstream Alfa/Beta binary package. Which may also help because Mozilla always want bugreports based on its binaries, or reproductible with them.

Note You need to log in before you can comment on or make changes to this bug.