Bug 962044 - KeyError: "3d-printing" traceback while doing groupinstall
KeyError: "3d-printing" traceback while doing groupinstall
Status: CLOSED DUPLICATE of bug 928859
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 03:53 EDT by Jaroslav Reznik
Modified: 2013-05-13 03:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 03:11:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-05-11 03:53:42 EDT
Description of problem: traceback after "yum groupinstall XXXX"

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 219, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 697, in doTransaction
    resultobject = self.runTransaction(cb=cb)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1763, in runTransaction
    self.igroups.save()
  File "/usr/lib/python2.7/site-packages/yum/igroups.py", line 148, in save
    self._write_grp_grps()
  File "/usr/lib/python2.7/site-packages/yum/igroups.py", line 175, in _write_grp_grps
    if self.groups[grpname].environment == evgrp.evgid:
KeyError: '3d-printing'

Version-Release number of selected component (if applicable):
yum-3.4.3-83.fc19.noarch

Steps to Reproduce:
1. yum groupinstall "GNOME Desktop"
  
Actual results:
Traceback but transaction finished

Expected results:
No traceback

Additional info:
Not sure if this one is yum issue or generic issue with group 3d-printing group definition, so reporting against yum. Or even a problem with my configuration.
Comment 1 Jan Zeleny 2013-05-13 03:11:36 EDT

*** This bug has been marked as a duplicate of bug 928859 ***

Note You need to log in before you can comment on or make changes to this bug.