Bug 962059 - Build fail on s390*
Build fail on s390*
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pillow (Show other bugs)
rawhide
s390 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
:
Depends On: 962091
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-11 07:19 EDT by Roman Rakus
Modified: 2014-01-12 19:15 EST (History)
2 users (show)

See Also:
Fixed In Version: python-pillow-2.0.0-10.gitd1c6db8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 962091 (view as bug list)
Environment:
Last Closed: 2013-05-31 23:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2013-05-11 07:19:10 EDT
Just to make sure we don't forget about this.

http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1046643

Tests/test_file_webp.py:26: assert_image_equal(im, target) failed:
- got different content
Tests/test_file_webp.py:57: assert_image_similar(im, target, 20.0) failed:
- average pixel value difference 170.9089 > epsilon 20.0000
Comment 1 Roman Rakus 2013-05-11 13:27:40 EDT
Looks like the problem is in libwebp.
On s390 machine:
# ./dwebp /tmp/lena.webp -o ~/lena_webp_bits.png
Decoding of /tmp/lena.webp failed.
Status: 5 (SUSPENDED)

/tmp/lena.webp is created locally by:
# ./cwebp ~/rpmbuild/BUILD/python-imaging-Pillow-d1c6db8/Images/lena.png -o /tmp/lena.webp
Comment 2 Roman Rakus 2013-05-13 09:12:51 EDT
Just a note: It's easy to not include webp support (just don't require
libwebp-devel package).

So I will turn off webp support on s390* archs.
Sandro, any objections?
Comment 3 Sandro Mani 2013-05-13 12:40:19 EDT
Nope, no objections
Comment 4 Fedora Update System 2013-05-13 17:46:14 EDT
python-pillow-2.0.0-10.gitd1c6db8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-pillow-2.0.0-10.gitd1c6db8.fc19
Comment 5 Fedora Update System 2013-05-13 23:45:36 EDT
Package python-pillow-2.0.0-10.gitd1c6db8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-pillow-2.0.0-10.gitd1c6db8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8114/python-pillow-2.0.0-10.gitd1c6db8.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-05-31 23:16:58 EDT
python-pillow-2.0.0-10.gitd1c6db8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.